summary refs log tree commit diff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-08-25 13:29:52 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-27 15:24:46 +0200
commit3ffceba52d9ad1871850b567503a33482e996bf4 (patch)
treeadb6d1d912dac26fae508aef531c127af794a52b
parentf37e2388d0b777793a711c817a7ee0826d8cdc9f (diff)
downloadguix-3ffceba52d9ad1871850b567503a33482e996bf4.tar.gz
gnu: Add emacs-auth-source-xoauth2.
* gnu/packages/emacs-xyz.scm (emacs-auth-source-xoauth2): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e5ceef86a0..98c1cf2729 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12474,6 +12474,28 @@ needs to be refreshed, the code handles it automatically and stores the new
 value of the access token.")
     (license license:gpl3+)))
 
+(define-public emacs-auth-source-xoauth2
+  (package
+    (name "emacs-auth-source-xoauth2")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ccrusius/auth-source-xoauth2")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0nl859csl8xcd6ybpjj15ph8l8fxwkwf45kbylss68alkyf1rl3v"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/ccrusius/auth-source-xoauth2")
+    (synopsis "XOAuth2 authentication capabilities for Emacs auth-source")
+    (description
+     "This package adds XOAuth2 authentication capabilities to Emacs
+auth-source.  This integration requires some preliminary work on the users’
+part, which includes creating tokens.")
+    (license license:asl2.0)))
+
 (define-public emacs-circe
   (package
     (name "emacs-circe")