summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-13 00:50:00 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:36:42 +0200
commit55fe84c6ebd37e6ee82114d4fc2c09ed42d1b3c0 (patch)
tree6de98c19ddc4f318b66189cd39e4a1ace20029af
parentada061c12ac86b430a6fdfc662cd9cb4217da67c (diff)
downloadguix-55fe84c6ebd37e6ee82114d4fc2c09ed42d1b3c0.tar.gz
gnu: Remove python2-gst.
It fails to build because of an incomplete python2 transformation, but is not
worth fixing because Python 2 is EOL and nothing depends on this package.

* gnu/packages/gstreamer.scm (python-gst)[properties]: Remove.
(python2-gst): Remove variable.
-rw-r--r--gnu/packages/gstreamer.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a3334b1772..01474e29a7 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -921,18 +921,7 @@ non-linear editors.")
     (description
      "This package contains GObject Introspection overrides for Python that can
 be used by Python applications using GStreamer.")
-    (license license:lgpl2.1+)
-    (properties `((python2-variant . ,(delay python2-gst))))))
-
-(define-public python2-gst
-  (package (inherit python-gst)
-    (name "python2-gst")
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("python" ,python-2)))
-    (propagated-inputs
-     `(("gst-plugins-base" ,gst-plugins-base)
-       ("python-pygobject" ,python2-pygobject)))))
+    (license license:lgpl2.1+)))
 
 (define-public gst123
   (package