summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-26 17:55:23 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commit0939da6e4d4309bde3923f46e59f7232c6ad5afc (patch)
tree554e78fdb49d7800906e888506ebc4a67aeafa7f
parent7d5baa300dbad8d4d9041f75dc063b4ac2d18064 (diff)
downloadguix-0939da6e4d4309bde3923f46e59f7232c6ad5afc.tar.gz
gnu: Add ghc-paths.
* gnu/packages/haskell.scm: (ghc-paths): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d02c5f946a..eacfa2da5f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -253,4 +253,27 @@ by Mark P Jones, in 'Advanced School of Functional Programming', 1995
 http://web.cecs.pdx.edu/~mpj/pubs/springschool.html.")
   (license bsd-3)))
 
+(define-public ghc-paths
+  (package
+    (name "ghc-paths")
+    (version "0.1.0.9")
+    (outputs '("out" "doc"))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/ghc-paths/ghc-paths-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0ibrr1dxa35xx20cpp8jzgfak1rdmy344dfwq4vlq013c6w8z9mg"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/simonmar/ghc-paths")
+    (synopsis
+     "Knowledge of GHC's installation directories")
+    (description
+     "Knowledge of GHC's installation directories.")
+    (license bsd-3)))
+
 ;;; haskell.scm ends here