summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-31 03:41:50 -0500
committerMark H Weaver <mhw@netris.org>2015-01-07 12:33:32 -0500
commit84cbe39c5a21495647ab6528715c42e4c5b94e83 (patch)
tree1da190d06260f5a2448de2557452673182f3eee9
parent2959dbe935f17bdcc19405067aa7353d8cc98c48 (diff)
downloadguix-84cbe39c5a21495647ab6528715c42e4c5b94e83.tar.gz
gnu: bootstrap: Fix egrep and fgrep after unpacking bootstrap binaries.
* gnu/packages/bootstrap.scm (%bootstrap-coreutils&co): Add #:snippet argument
  to 'package-from-tarball' that calls 'patch-shebang' on egrep and fgrep
  after unpacking.  Test 'fgrep' instead of 'true'.
-rw-r--r--gnu/packages/bootstrap.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 05444dd017..f1110d9cf0 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -264,8 +264,15 @@ $out/bin/guile --version~%"
                               ("mips64el-linux"
                                (base32
                                 "072y4wyfsj1bs80r6vbybbafy8ya4vfy7qj25dklwk97m6g71753"))))))
-                        "true"                    ; the program to test
-                        "Bootstrap binaries of Coreutils, Awk, etc."))
+                        "fgrep"                    ; the program to test
+                        "Bootstrap binaries of Coreutils, Awk, etc."
+                        #:snippet
+                        '(let ((path (list (string-append (getcwd) "/bin"))))
+                           (chmod "bin" #o755)
+                           (patch-shebang "bin/egrep" path)
+                           (patch-shebang "bin/fgrep" path)
+                           (chmod "bin" #o555)
+                           #t)))
 
 (define %bootstrap-binutils
   (package-from-tarball "binutils-bootstrap"