summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-14 23:37:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-14 23:45:35 +0200
commitc6e45a93d4a0ffdeaeba87e852b4204f75e318ed (patch)
tree0cab19ac521c8ac50d7746134df33887c5f236ce
parent2dedc16b04d16897c62b363d5e0091b30728252e (diff)
downloadguix-c6e45a93d4a0ffdeaeba87e852b4204f75e318ed.tar.gz
gnu: gx-super-fuzz-lv2: Fix SSE detection.
* gnu/packages/music.scm (gx-super-fuzz-lv2)[arguments]: Add phase
"escape-shell-commands".
-rw-r--r--gnu/packages/music.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 87dd5f2cf9..51f391b691 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2243,6 +2243,17 @@ parallel with a DarkBooster, followed by a volume control."))))
                  (base32
                   "1jclp53p01h94cpx17wm4765r7klbr41g7bvq87l53qwlrgkc7a9"))
                 (file-name (string-append name "-" version "-checkout"))))
+      (arguments
+       (substitute-keyword-arguments (package-arguments gx-guvnor-lv2)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'escape-shell-commands
+               (lambda _
+                 (substitute* "Makefile"
+                   (("cat ") "$(shell cat ")
+                   (("/dev/null") "/dev/null)")
+                   (("SSE_CFLAGS = \"\"") "SSE_CFLAGS ="))
+                 #t))))))
       (home-page "https://github.com/brummer10/GxSuperFuzz.lv2")
       (synopsis "Fuzz effect modelled after the UniVox SuperFuzz")
       (description "This package provides the LV2 plugin \"GxVoodooFuzz\", an