summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-23 23:26:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-23 23:26:04 +0100
commit02bf685d00238f74d28211e71d22a03f58e962cd (patch)
tree00d0bc1ef3fd74b6dc5d3ce68cb24835bf07a91f
parent472c36bd36696cfe744e8a7b8f4d4ac5800e0f68 (diff)
parent8f2253af7da1c537b4c11e6b43c8d0a9f026b609 (diff)
downloadguix-02bf685d00238f74d28211e71d22a03f58e962cd.tar.gz
Merge branch 'master' into staging
-rw-r--r--doc/guix.texi4
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/conkeror.scm83
-rw-r--r--gnu/packages/datamash.scm7
-rw-r--r--gnu/packages/emacs.scm4
-rw-r--r--gnu/packages/entr.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/gnuzilla.scm5
-rw-r--r--gnu/packages/image-processing.scm5
-rw-r--r--gnu/packages/linux.scm16
-rw-r--r--gnu/packages/mail.scm25
-rw-r--r--gnu/packages/maths.scm34
-rw-r--r--gnu/packages/patches/datamash-arm-tests.patch71
-rw-r--r--gnu/packages/serialization.scm20
-rw-r--r--gnu/packages/textutils.scm33
-rw-r--r--gnu/packages/web-browsers.scm18
-rw-r--r--gnu/services/admin.scm2
-rw-r--r--guix/scripts/offload.scm2
18 files changed, 117 insertions, 218 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index c942908997..b14c8e0020 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -17699,7 +17699,7 @@ A service type for the @code{fcgiwrap} FastCGI proxy.
 @end defvr
 
 @deftp {Data Type} fcgiwrap-configuration
-Data type representing the configuration of the @code{fcgiwrap} serice.
+Data type representing the configuration of the @code{fcgiwrap} service.
 This type has the following parameters:
 @table @asis
 @item @code{package} (default: @code{fcgiwrap})
@@ -17874,7 +17874,7 @@ The cat avatar generator is a simple service to demonstrate the use of php-fpm
 in @code{Nginx}.  It is used to generate cat avatar from a seed, for instance
 the hash of a user's email address.
 
-@deffn {Scheme Procedure} cat-avatar-generator-serice @
+@deffn {Scheme Procedure} cat-avatar-generator-service @
        [#:cache-dir "/var/cache/cat-avatar-generator"] @
        [#:package cat-avatar-generator] @
        [#:configuration (nginx-server-configuration)]
diff --git a/gnu/local.mk b/gnu/local.mk
index 3e205a8f0a..713050be72 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -109,7 +109,6 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/commencement.scm			\
   %D%/packages/compression.scm			\
   %D%/packages/compton.scm 			\
-  %D%/packages/conkeror.scm			\
   %D%/packages/conky.scm			\
   %D%/packages/connman.scm			\
   %D%/packages/cook.scm				\
@@ -648,7 +647,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/cube-nocheck.patch			\
   %D%/packages/patches/cursynth-wave-rand.patch			\
   %D%/packages/patches/cvs-2017-12836.patch			\
-  %D%/packages/patches/datamash-arm-tests.patch			\
   %D%/packages/patches/dbus-helper-search-path.patch		\
   %D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch	\
   %D%/packages/patches/dfu-programmer-fix-libusb.patch		\
diff --git a/gnu/packages/conkeror.scm b/gnu/packages/conkeror.scm
deleted file mode 100644
index 6145dbf445..0000000000
--- a/gnu/packages/conkeror.scm
+++ /dev/null
@@ -1,83 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
-;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages conkeror)
-  #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu)
-  #:use-module (gnu packages)
-  #:use-module (gnu packages gnuzilla))
-
-(define-public conkeror
-  (package
-    (name "conkeror")
-    (version "1.1.0")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "http://repo.or.cz/conkeror.git/snapshot/"
-                              version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0jz216mjwis7f03j98s4wkcrrq2j3f41fb2y47a5qszc340zhdzv"))))
-    (build-system gnu-build-system)
-    (inputs `(("icecat" ,icecat)))
-    (arguments
-     `(#:tests? #f                      ;no tests
-       #:make-flags `("CC=gcc"
-                      ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (add-after
-          'install 'install-app-launcher
-          (lambda* (#:key inputs outputs #:allow-other-keys)
-            ;; This overwrites the installed launcher, which execs xulrunner,
-            ;; with one that execs 'icecat --app'
-            (let* ((out      (assoc-ref outputs "out"))
-                   (datadir  (string-append out "/share/conkeror"))
-                   (launcher (string-append out "/bin/conkeror")))
-              (call-with-output-file launcher
-                (lambda (p)
-                  (format p "#!~a/bin/bash
-exec ~a/bin/icecat --app ~a \"$@\"~%"
-                          (assoc-ref inputs "bash") ;implicit input
-                          (assoc-ref inputs "icecat")
-                          (string-append datadir
-                                         "/application.ini"))))
-              (chmod launcher #o555)))))))
-    (synopsis "Keyboard focused web browser with Emacs look and feel")
-    (description "Conkeror is a highly-programmable web browser based on
-Mozilla XULRunner which is the base of all Mozilla products including Firefox.
-Conkeror has a sophisticated keyboard system for running commands and
-interacting with web page content, modelled after Emacs and Lynx.  It is
-self-documenting and extensible with JavaScript.
-
-It comes with builtin support for several Web 2.0 sites like several Google
-services (Search, Gmail, Maps, Reader, etc.), Del.icio.us, Reddit, Last.fm and
-YouTube.  For easier editing of form fields, it can spawn external editors.")
-    (home-page "http://conkeror.org")
-    ;; Conkeror is triple licensed.
-    (license (list
-              ;; MPL 1.1 -- this license is not GPL compatible
-              license:gpl2
-              license:lgpl2.1))))
diff --git a/gnu/packages/datamash.scm b/gnu/packages/datamash.scm
index 182d281a5d..81b0069aab 100644
--- a/gnu/packages/datamash.scm
+++ b/gnu/packages/datamash.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,7 +29,7 @@
 (define-public datamash
   (package
     (name "datamash")
-    (version "1.3")
+    (version "1.4")
     (source
      (origin
       (method url-fetch)
@@ -37,8 +37,7 @@
                           version ".tar.gz"))
       (sha256
        (base32
-        "19jpcv4ryvbz0476d6dgpxpbjkpmih4q84wj06nslls338bm5fzf"))
-      (patches (search-patches "datamash-arm-tests.patch"))))
+        "0aj7wvv14s2fsf2rl49mqhxdagy8cbz6rz4xyi7bkg2nahnxsi7s"))))
     (native-inputs
      `(("which" ,which)                 ;for tests
        ("perl" ,perl)))                 ;for help2man
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 52c9d478b6..262517a73e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1753,14 +1753,14 @@ type, for example: packages, buffers, files, etc.")
 (define-public emacs-guix
   (package
     (name "emacs-guix")
-    (version "0.5")
+    (version "0.5.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://emacs-guix.gitlab.io/website/"
                                   "releases/emacs-guix-" version ".tar.gz"))
               (sha256
                (base32
-                "09zxd8x674vrpigmcx8l00ifhaxh35xwkwjb8dw9kydnhv9hyyi1"))))
+                "1gwihi08pz52zbv11lhwcdzsbmcbqvjf8j0ic56543v7nlmywkxh"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index dfa9274bea..11d28e60f7 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -56,7 +56,7 @@
     (home-page "http://entrproject.org/")
     (synopsis "Run arbitrary commands when files change")
     (description
-     "entr is a zero-configuration tool with no external build- or run-time
+     "entr is a zero-configuration tool with no external build or run-time
 dependencies.  The interface to entr is not only minimal, it aims to be simple
 enough to create a new category of ad hoc automation.  These micro-tests
 reduce keystrokes, but more importantly they emphasize the utility of
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2ef93d6247..4ab0af2e77 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1309,7 +1309,7 @@ fight Morgoth, the Lord of Darkness.")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)))) ; no configure script
-    (home-page "http://pingus.seul.org/welcome.html")
+    (home-page "https://pingus.seul.org/")
     (synopsis "Lemmings clone")
     (description
      "Pingus is a free Lemmings-like puzzle game in which the player takes
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index dc0fce6203..e95f87b7aa 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -903,3 +903,8 @@ features built-in privacy-protecting features.")
      `((ftp-directory . "/gnu/gnuzilla")
        (cpe-name . "firefox_esr")
        (cpe-version . ,(first (string-split version #\-)))))))
+
+(define-public conkeror
+  ;; The Conkeror web browser relied on XULRunner, which IceCat > 50 no longer
+  ;; provides.  See <http://conkeror.org> for the original web page.
+  (deprecated-package "conkeror" icecat))
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index df0099c7df..846d498cec 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -440,6 +440,7 @@ vision algorithms.  It can be used to do things like:
        ("expat" ,expat)
        ("hdf5" ,hdf5)))
     (home-page "https://libvips.github.io/libvips/")
-    (synopsis "A free image processing system")
-    (description "vips is a demand-driven, horizontally threaded image processing library")
+    (synopsis "Image processing system")
+    (description
+     "vips is a demand-driven, horizontally threaded image processing library.")
     (license license:lgpl2.1+)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6f0f68b8c0..cbcd88f372 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -400,8 +400,8 @@ It has been modified to remove all non-free binary blobs.")
 ;; supports qemu "virt" machine and possibly a large number of ARM boards.
 ;; See : https://wiki.debian.org/DebianKernel/ARMMP.
 
-(define %linux-libre-version "4.19.11")
-(define %linux-libre-hash "1wsxh2hdb4g18vwhr91rm964g801k7ign3p353211gahpdvzay5c")
+(define %linux-libre-version "4.19.12")
+(define %linux-libre-hash "1cgcg3bw55adx3ivk1aiivrqx5p0ydbz1hzjwzwns0cdqi838cyp")
 
 (define %linux-libre-4.19-patches
   (list %boot-logo-patch
@@ -423,8 +423,8 @@ It has been modified to remove all non-free binary blobs.")
                     #:patches %linux-libre-4.19-patches
                     #:configuration-file kernel-config))
 
-(define %linux-libre-4.14-version "4.14.89")
-(define %linux-libre-4.14-hash "12n6qpcng7c7vdb1p3p914bn3g2namaam6d55ipvz0dv5k283h75")
+(define %linux-libre-4.14-version "4.14.90")
+(define %linux-libre-4.14-hash "19my91gb54whgk83vyd45ri0c3jb57jfdb670s80fp02ilr7x5ka")
 
 (define-public linux-libre-4.14
   (make-linux-libre %linux-libre-4.14-version
@@ -433,14 +433,14 @@ It has been modified to remove all non-free binary blobs.")
                     #:configuration-file kernel-config))
 
 (define-public linux-libre-4.9
-  (make-linux-libre "4.9.146"
-                    "0z1jdpa5z3kcgl29am19rvips03w7hr106rc3p9rzggblr623dy5"
+  (make-linux-libre "4.9.147"
+                    "0gpzf04lmwxh675lam4m8pbwrgxzd7y1y50b6yfzhxa4bb3c4yfb"
                     %intel-compatible-systems
                     #:configuration-file kernel-config))
 
 (define-public linux-libre-4.4
-  (make-linux-libre "4.4.168"
-                    "12wb8fjmgkal1s4sfkfa5gi8bza22ah4p762gl33v4qc9nvjmmpf"
+  (make-linux-libre "4.4.169"
+                    "1snjdih9iv3fg7f9h2r1gldcqmvzj1w398aysws4fialj488x1p4"
                     %intel-compatible-systems
                     #:configuration-file kernel-config))
 
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ed8654b221..6d1006c606 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -486,15 +486,16 @@ and corrections.  It is based on a Bayesian filter.")
 (define-public offlineimap
   (package
     (name "offlineimap")
-    (version "7.2.1")
+    (version "7.2.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/OfflineIMAP/offlineimap/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/OfflineIMAP/offlineimap")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1022xf2w1xax4vx4kzhlfbhaf0b72wkpvrcscvs4q8qk2ja68h8x"))))
+                "11nj7y9fa7v6vcxk3wr8smfgm3mxxnmq3l8q69rrjxlfzcv7dl8m"))))
     (build-system python-build-system)
     (native-inputs
      `(("asciidoc" ,asciidoc)))
@@ -527,7 +528,7 @@ and corrections.  It is based on a Bayesian filter.")
                (wrap-program bin
                  `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
                #t))))))
-    (home-page "http://www.offlineimap.org")
+    (home-page "https://www.offlineimap.org")
     (synopsis "Sync emails between two repositories")
     (description
      "OfflineImap synchronizes emails between two repositories, so that you
@@ -942,7 +943,7 @@ useful features.")
 (define-public libetpan
   (package
     (name "libetpan")
-    (version "1.9.1")
+    (version "1.9.2")
     (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -950,7 +951,7 @@ useful features.")
                    (commit version)))
              (file-name (git-file-name name version))
              (sha256
-               (base32 "1628lb1qvxixl64ifvjjr839hmirpx532klhv2mr7m6gmn7nlci5"))))
+               (base32 "13jiy2ddxbp9f2mk1mip9sk8h97bva5m0pnq2mlvh5xhifs6gza4"))))
     (build-system gnu-build-system)
     (native-inputs `(("autoconf" ,autoconf-wrapper)
                      ("automake" ,automake)
@@ -1007,15 +1008,15 @@ compresses it.")
 (define-public claws-mail
   (package
     (name "claws-mail")
-    (version "3.17.1")
+    (version "3.17.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://www.claws-mail.org/releases/" name "-" version
+                    "https://www.claws-mail.org/releases/claws-mail-" version
                     ".tar.xz"))
               (sha256
                (base32
-                "1wknxbwyzm5xjh3cqmddcxmvp1rkp301qga5n5rgfi7vcd0myyvm"))))
+                "1wnj6c9cbmhphs2l6wfvndkk2g08rmxw0sl2c8k1k008dxd1ykjh"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("bogofilter" ,bogofilter)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ec23d6f572..c6cecb703c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -29,6 +29,7 @@
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,7 +54,7 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
-  #:use-module (guix build utils)
+  #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system ocaml)
@@ -63,6 +64,7 @@
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -3965,7 +3967,7 @@ as equations, scalars, vectors, and matrices.")
 (define-public z3
   (package
     (name "z3")
-    (version "4.8.1")
+    (version "4.8.3")
     (home-page "https://github.com/Z3Prover/z3")
     (source (origin
               (method git-fetch)
@@ -3974,16 +3976,10 @@ as equations, scalars, vectors, and matrices.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1vr57bwx40sd5riijyrhy70i2wnv9xrdihf6y5zdz56yq88rl48f"))))
-    (build-system cmake-build-system)
+                "0p5gdmhd32x6zwmx7j5cgwh4jyfxa9yapym95nlmyfaqzak92qar"))))
+    (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list "-DBUILD_PYTHON_BINDINGS=true"
-             "-DINSTALL_PYTHON_BINDINGS=true"
-             (string-append "-DCMAKE_INSTALL_PYTHON_PKG_DIR="
-                            %output
-                            "/lib/python2.7/site-packages"))
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-compatability
            ;; Versions after 4.8.3 have immintrin.h IFDEFed for Windows only.
@@ -3994,7 +3990,18 @@ as equations, scalars, vectors, and matrices.")
          (add-before 'configure 'bootstrap
            (lambda _
              (zero?
-              (system* "python" "contrib/cmake/bootstrap.py" "create"))))
+              (system* "python" "scripts/mk_make.py"))))
+         ;; work around gnu-build-system's setting --enable-fast-install
+         ;; (z3's `configure' is a wrapper around the above python file,
+         ;; which fails when passed --enable-fast-install)
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (invoke "./configure"
+                     (string-append "--prefix=" (assoc-ref outputs "out")))))
+         (add-after 'configure 'change-directory
+           (lambda _
+             (chdir "build")
+             #t))
          (add-before 'check 'make-test-z3
            (lambda _
              ;; Build the test suite executable.
@@ -4005,7 +4012,8 @@ as equations, scalars, vectors, and matrices.")
              ;; Run all the tests that don't require arguments.
              (zero? (system* "./test-z3" "/a")))))))
     (native-inputs
-     `(("python" ,python-2)))
+     `(("which" ,which)
+       ("python" ,python-wrapper)))
     (synopsis "Theorem prover")
     (description "Z3 is a theorem prover and @dfn{satisfiability modulo
 theories} (SMT) solver.  It provides a C/C++ API, as well as Python bindings.")
diff --git a/gnu/packages/patches/datamash-arm-tests.patch b/gnu/packages/patches/datamash-arm-tests.patch
deleted file mode 100644
index a24c5320ad..0000000000
--- a/gnu/packages/patches/datamash-arm-tests.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-See https://lists.gnu.org/archive/html/bug-datamash/2018-03/msg00003.html and
-https://lists.gnu.org/archive/html/bug-datamash/2018-03/txt4DmvR7p6J9.txt
-
-From d446dba317aa067440d6312d955d523129949327 Mon Sep 17 00:00:00 2001
-From: Assaf Gordon <address@hidden>
-Date: Thu, 22 Mar 2018 11:00:34 -0600
-Subject: [PATCH 1/2] tests: fix --format='%4000f' expected output
-
-Can be 1.000009... or 1.000008999, depending on representation.
-
-* tests/datamash-output-format.pl: Check only the first 5 digits.
----
- tests/datamash-output-format.pl | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/tests/datamash-output-format.pl b/tests/datamash-output-format.pl
-index 52c68a2..ca99bb0 100755
---- a/tests/datamash-output-format.pl
-+++ b/tests/datamash-output-format.pl
-@@ -98,12 +98,13 @@ my @Tests =
-    {OUT => "0" x 3999 . "1\n"}],
- 
-   # due to binary floating representation, some decimal point digits won't be
--  # zero (e.g. 1.0000090000000000000000000000000523453254320000000...).
--  # The OUT_SUBST replaces exactly 3994 digits (as expected from the format)
-+  # zero (e.g. 1.0000090000000000000000000000000523453254320000000... or
-+  # 1.000008999999...).
-+  # The OUT_SUBST replaces exactly 3995 digits (as expected from the format)
-   # with an "X".
-   ['m2', '--format "%.4000f"   sum 1',  {IN_PIPE=>$in1},
--   {OUT => "1.000009X\n"},
--   {OUT_SUBST => 's/^(1\.000009)([0-9]{3994})$/\1X/'}],
-+   {OUT => "1.00000X\n"},
-+   {OUT_SUBST => 's/^(1\.00000)([0-9]{3995})$/\1X/'}],
- 
- );
- 
--- 
-2.7.4
-
-
-From f4871963974a96d6e69cb80b9c2fac7ff0c1d472 Mon Sep 17 00:00:00 2001
-From: Assaf Gordon <address@hidden>
-Date: Thu, 22 Mar 2018 11:18:13 -0600
-Subject: [PATCH 2/2] tests: disable --format="%a" test
-
-Valid output can differ (e.g. 0x8.000p-3 vs 0x1.000p+0).
-
-* tests/datamash-output-format.pl: Disable 'a1' test.
----
- tests/datamash-output-format.pl | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/tests/datamash-output-format.pl b/tests/datamash-output-format.pl
-index ca99bb0..5e90ae0 100755
---- a/tests/datamash-output-format.pl
-+++ b/tests/datamash-output-format.pl
-@@ -90,7 +90,9 @@ my @Tests =
-   ['e2', '--format "%.3e"  sum 1', {IN_PIPE=>$in1}, {OUT=>"1.000e+00\n"}],
- 
-   # Test Custom formats: %a
--  ['a1', '--format "%0.3a" sum 1', {IN_PIPE=>$in1}, {OUT=>"0x8.000p-3\n"}],
-+  # Disable the test for now. Valid output can differ (e.g. 0x8.000p-3 and
-+  # 0x1.000p0 ).
-+  # ['a1', '--format "%0.3a" sum 1', {IN_PIPE=>$in1}, {OUT=>"0x8.000p-3\n"}],
- 
- 
-   # Custom formats can use lots of memory
--- 
-2.7.4
-
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 71fae465d8..b85c507d64 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -271,7 +271,23 @@ that implements both the msgpack and msgpack-rpc specifications.")
                 "01gxn7kc8pzyh4aadjxxzq8cignmbwmm9rfrsmgqfg9w2q75dn74"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'dont-install-gtest-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (with-directory-excursion
+                 (string-append out "/include")
+                 (delete-file-recursively "gtest")
+                 (delete-file-recursively "gmock"))
+               (with-directory-excursion
+                 (string-append out "/lib")
+                 (for-each (lambda (file)
+                             (delete-file file))
+                           '("libgmock.so" "libgmock_main.so"
+                             "libgtest.so" "libgtest_main.so"))))
+             #t)))))
     (native-inputs
      `(("python" ,python)))
     (home-page "https://github.com/jbeder/yaml-cpp")
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index cda79231f1..91bc64bc1f 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -52,7 +52,8 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
-  #:use-module (gnu packages slang))
+  #:use-module (gnu packages slang)
+  #:use-module (gnu packages web))
 
 (define-public dos2unix
   (package
@@ -758,15 +759,33 @@ indentation.
     (version "1.0.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/BYVoid/OpenCC"
-                           "/archive/ver." version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/BYVoid/OpenCC")
+              (commit (string-append "ver." version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "01870gbkf711msirf3206k0ajaabypjhnx3fny5wikw0ladn9q8w"))))
+        (base32
+         "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; TODO: Unbundle tclap, darts-clone, gtest
+           (delete-file-recursively "deps/rapidjson-0.11") #t))))
     (build-system cmake-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-3rd-party-references
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((rapidjson (assoc-ref inputs "rapidjson")))
+               (substitute* "src/CMakeLists.txt"
+                 (("../deps/rapidjson-0.11")
+                  (string-append rapidjson "/include/rapidjson")))
+             #t))))))
     (native-inputs
-     `(("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)
+       ("rapidjson" ,rapidjson)))
     (home-page "https://github.com/BYVoid/OpenCC")
     (synopsis "Convert between Traditional Chinese and Simplified Chinese")
     (description "Open Chinese Convert (OpenCC) converts between Traditional
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 0fea571f1a..e1ad01aa25 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -50,6 +50,7 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages gcc)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
@@ -366,7 +367,7 @@ driven and does not detract you from your daily work.")
 (define-public next-gtk-webkit
   (package
     (name "next-gtk-webkit")
-    (version "1.1.0")
+    (version "1.2.0")
     (source
      (origin
        (method git-fetch)
@@ -375,13 +376,16 @@ driven and does not detract you from your daily work.")
              (commit version)))
        (sha256
         (base32
-         "00xi01r6gxlrv7xc2dhf4da30y0vng1snbdmc8d829qyn0chl55q"))
+         "0a066f56hnb9znbwnv1blm31j0ysv05n4wzlkli0zgw087c9047x"))
        (file-name (git-file-name "next" version))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
        #:make-flags (list "gtk-webkit"
-                          "CC=gcc"
+                          (string-append
+                           "CC="
+                           (assoc-ref %build-inputs "gcc-7")
+                           "/bin/gcc")
                           (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases
@@ -392,9 +396,10 @@ driven and does not detract you from your daily work.")
     (inputs
      `(("glib-networking" ,glib-networking)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("webkitgtk" ,webkitgtk)))
+       ("webkitgtk" ,webkitgtk-2.22)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("gcc-7" ,gcc-7) ; needed because webkitgtk-2.22 is compiled with gcc-7
+       ("pkg-config" ,pkg-config)))
     (home-page "https://next.atlas.engineer")
     (synopsis "Infinitely extensible web-browser (user interface only)")
     (description "Next is a keyboard-oriented, extensible web-browser
@@ -464,5 +469,6 @@ features for productive professionals.")
        ("cl-css" ,sbcl-cl-css)
        ("bordeaux-threads" ,sbcl-bordeaux-threads)
        ("s-xml-rpc" ,sbcl-s-xml-rpc)
-       ("unix-opts" ,sbcl-unix-opts)))
+       ("unix-opts" ,sbcl-unix-opts)
+       ("trivial-clipboard" ,sbcl-trivial-clipboard)))
     (synopsis "Infinitely extensible web-browser (with Lisp development files)")))
diff --git a/gnu/services/admin.scm b/gnu/services/admin.scm
index d7bda61ed7..a3e43dd1c1 100644
--- a/gnu/services/admin.scm
+++ b/gnu/services/admin.scm
@@ -14,7 +14,7 @@
 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 ;;; GNU General Public License for more details.
 ;;;
-;;; You should have received a copy of thye GNU General Public License
+;;; You should have received a copy of the GNU General Public License
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu services admin)
diff --git a/guix/scripts/offload.scm b/guix/scripts/offload.scm
index 1e0ea1c4c6..bfdaa3c011 100644
--- a/guix/scripts/offload.scm
+++ b/guix/scripts/offload.scm
@@ -733,7 +733,7 @@ machine."
                           (utsname:sysname uts) (utsname:release uts)
                           (utsname:machine uts)
                           (utsname:nodename uts)
-                          load
+                          (normalized-load machine load)
                           (/ free (expt 2 20) 1.))))
               machines)))