summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-12 00:16:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:01 +0100
commit248f65269a51ed8a541f4db06e39fae2a2733aff (patch)
tree255cb63a717187bd4dd31c6a51e181c6eb596680
parent69e14f9ec756996e4e4dbcb57444cdb7ac1a642b (diff)
downloadguix-248f65269a51ed8a541f4db06e39fae2a2733aff.tar.gz
gnu: Add r-nlme.
* gnu/packages/statistics.scm (r-nlme): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 23d6c9392b..c072bcbcba 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -406,6 +406,29 @@ also flexible enough to handle most nonstandard requirements.")
 and operations on them using LAPACK and SuiteSparse.")
     (license license:gpl2+)))
 
+(define-public r-nlme
+  (package
+    (name "r-nlme")
+    (version "3.1-131")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "nlme" version))
+       (sha256
+        (base32
+         "0k2nvdzhic6bzhfsbq6la6q6a1i5nlj4pnh6lpdxiiwvxdks3nkr"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "http://cran.r-project.org/web/packages/nlme")
+    (synopsis "Linear and nonlinear mixed effects models")
+    (description
+     "This package provides tools to fit and compare Gaussian linear and
+nonlinear mixed-effects models.")
+    (license license:gpl2+)))
+
 (define-public r-bit
   (package
     (name "r-bit")