summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 18:40:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:33 +0100
commit25b2c47d753efd0761a4e16519dce38d828789f5 (patch)
treeede270c3cecbebd302e63f6858349c35b7462c5c
parentd5e41cf28ca400cc1ce060945518f77cc9efc818 (diff)
downloadguix-25b2c47d753efd0761a4e16519dce38d828789f5.tar.gz
gnu: python-statsmodels: Fix build
* gnu/packages/statistics.scm (python-statsmodels): [check] set
  PYTHONPATH prior to running tests.
-rw-r--r--gnu/packages/statistics.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cca08d26a8..3461799420 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1444,11 +1444,13 @@ building design matrices.")
                               line)))
             #t))
          (add-after 'install 'check
-          (lambda _
-            (with-directory-excursion "/tmp"
-              (zero? (system* "nosetests"
-                              "--stop"
-                              "-v" "statsmodels"))))))))
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Make installed package available for running the tests
+             (add-installed-pythonpath inputs outputs)
+             (with-directory-excursion "/tmp"
+               (zero? (system* "nosetests"
+                               "--stop"
+                               "-v" "statsmodels"))))))))
     (propagated-inputs
      `(("python-numpy" ,python-numpy)
        ("python-scipy" ,python-scipy)