summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-09-13 19:28:36 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-09-13 20:20:41 +0800
commit26700caed91b967bf365e29eb576cc23b84a502f (patch)
tree931819644c4145ed5bdb82be1817be2ffb136a8b
parentac4d2ec81a9f7c439b21b4c4ae4a2e949c78ab2e (diff)
downloadguix-26700caed91b967bf365e29eb576cc23b84a502f.tar.gz
gnu: racket: Fix incompatibility with libedit.
The former patching made racket detecting libedit as the old 2.11 version,
which leads to failure:
<https://lists.gnu.org/archive/html/help-guix/2018-09/msg00027.html>.

* gnu/packages/scheme.scm (racket)[arguments]: Patch the 'ffi-lib' call of
libedit using 'PLT_READLINE_LIB'.
-rw-r--r--gnu/packages/scheme.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 926169ce18..2e46a8453f 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -460,6 +460,9 @@ implementation techniques and as an expository tool.")
                (substitute* "share/pkgs/math-lib/math/private/bigfloat/mpfr.rkt"
                  (("ffi-lib libmpfr-so")
                   (format #f "ffi-lib \"~a\"" (find-so "libmpfr"))))
+               (substitute* "share/pkgs/readline-lib/readline/rktrl.rkt"
+                 (("\\(getenv \"PLT_READLINE_LIB\"\\)")
+                  (format #f "\"~a\"" (find-so "libedit"))))
                (for-each
                 (lambda (x) (apply patch-ffi-libs x))
                 '(("share/pkgs/draw-lib/racket/draw/unsafe/cairo-lib.rkt"
@@ -487,9 +490,7 @@ implementation techniques and as an expository tool.")
                   ("share/pkgs/gui-lib/mred/private/wx/gtk/gl-context.rkt"
                    ("libGL"))
                   ("share/pkgs/sgl/gl.rkt"
-                   ("libGL" "libGLU"))
-                  ("share/pkgs/readline-lib/readline/rktrl.rkt"
-                   ("libedit")))))
+                   ("libGL" "libGLU")))))
              (chdir "src")
              #t))
          (add-after 'unpack 'patch-/bin/sh