summary refs log tree commit diff
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2015-05-23 22:10:34 +0300
committerManolis Ragkousis <manolis837@gmail.com>2015-06-09 22:48:10 +0300
commit30347caae78d200573554d9e3734efc9ccc37d9c (patch)
treef8e905dd2e09b0576e92fe32cf26ef0161a4f392
parentf8badf151b4d2d966a1ebeba0345dfc9e4564d01 (diff)
downloadguix-30347caae78d200573554d9e3734efc9ccc37d9c.tar.gz
gnu: guile-static: Use Linux syscalls only on Linux-based systems.
* gnu/packages/patches/guile-linux-syscalls.patch: Use Linux
  syscalls only on Linux-based systems.
-rw-r--r--gnu/packages/patches/guile-linux-syscalls.patch6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/patches/guile-linux-syscalls.patch b/gnu/packages/patches/guile-linux-syscalls.patch
index 57c7f2589d..25a5e90e35 100644
--- a/gnu/packages/patches/guile-linux-syscalls.patch
+++ b/gnu/packages/patches/guile-linux-syscalls.patch
@@ -7,12 +7,13 @@ diff --git a/libguile/posix.c b/libguile/posix.c
 index 324f21b..cbee94d 100644
 --- a/libguile/posix.c
 +++ b/libguile/posix.c
-@@ -2286,6 +2286,261 @@ scm_init_popen (void)
+@@ -2245,6 +2245,263 @@ scm_init_popen (void)
  }
  #endif
  
 +
 +/* Linux! */
++#ifdef __linux__
 +
 +#include <sys/mount.h>
 +#include "libguile/foreign.h"
@@ -265,7 +266,10 @@ index 324f21b..cbee94d 100644
 +  return scm_from_short (ifr.ifr_flags);
 +}
 +#undef FUNC_NAME
++#endif
 +
  void
  scm_init_posix ()
  {
+-- 
+2.4.1