summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-28 20:55:06 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-12 22:59:36 +0100
commit3a58f45502fdc8734f5c8ef3ec5acf80c03a1cac (patch)
tree6d16823aead12c20d47ae95b1b2a349448c3aa8d
parent1fda01ef4222d71627572074fc691672e788a678 (diff)
downloadguix-3a58f45502fdc8734f5c8ef3ec5acf80c03a1cac.tar.gz
gnu: Add perl-moox.
* gnu/packages/perl.scm (perl-moox): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 249f478f96..6b41d5091f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5073,6 +5073,32 @@ all coercions and constraints are inherited.")
 constraint with coercion to load the class.")
     (license (package-license perl))))
 
+(define-public perl-moox
+  (package
+    (name "perl-moox")
+    (version "0.101")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/G/GE/GETTY/MooX-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1m9jvrqcidiabdih211byadwnnkygafq54r2ljnf1akqdrjimy9g"))))
+    (build-system perl-build-system)
+    (inputs
+     `(("perl-data-optlist" ,perl-data-optlist)
+       ("perl-import-into" ,perl-import-into)
+       ("perl-module-runtime" ,perl-module-runtime)
+       ("perl-moo" ,perl-moo)))
+    (home-page "http://search.cpan.org/dist/MooX")
+    (synopsis
+     "Using Moo and MooX:: packages the most lazy way")
+    (description "Contains the MooX and MooX::Role packages.")
+    (license perl-license)))
+
 (define-public perl-moox-types-mooselike
   (package
     (name "perl-moox-types-mooselike")