summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 18:42:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 18:43:07 +0100
commit45bc4b7ecb1a5a2aef379a36f20fc74ba3c5b10b (patch)
treeec1910052a14aa8b5d8da131501ee2119f1ae424
parent366cd7fcba3ef7a26c17f20fe07a65308d8f9186 (diff)
downloadguix-45bc4b7ecb1a5a2aef379a36f20fc74ba3c5b10b.tar.gz
gnu: python2-fasteners: Propagate python2-futures.
* gnu/packages/python.scm (python-fasteners)[properties]: New field.
(python2-fasteners)[propagated-inputs]: Add PYTHON2-FUTURES.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c23f2b5875..892199fc0f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14124,10 +14124,16 @@ introspection.")
 @item Inter-process locks
 @item Generic helpers
 @end itemize\n")
+    (properties `((python2-variant . ,(delay python2-fasteners))))
     (license license:asl2.0)))
 
 (define-public python2-fasteners
-  (package-with-python2 python-fasteners))
+  (let ((base (package-with-python2 (strip-python2-variant python-fasteners))))
+    (package
+      (inherit base)
+      (propagated-inputs
+       `(("python2-futures" ,python2-futures)
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-requests-file
   (package