summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:33:42 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit5c913ba159e285efb096c784473ababd15c233b0 (patch)
tree3cf3db278df87b6a9b6427b0d6661c049adb3f7b
parent37d52f6e4699030cf957da306fa9b66396eb9d71 (diff)
downloadguix-5c913ba159e285efb096c784473ababd15c233b0.tar.gz
gnu: extra-cmake-modules: Update to 5.24.0.
* gnu/packages/kde-frameworks.scm: Update to 5.24.0.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 57727accbc..838bdb39c9 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -30,21 +30,35 @@
 (define-public extra-cmake-modules
   (package
     (name "extra-cmake-modules")
-    (version "5.21.0")
+    (version "5.24.0")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://download.kde.org/stable/frameworks/"
+        (uri (string-append "mirror://kde/stable/frameworks/"
                             (version-major+minor version) "/"
                             name "-" version ".tar.xz"))
         (sha256
          (base32
-          "1kbc5fkcbz9vkg0jpz10vsfgwajlrsmbl0vrbls5qvrdgbgrwlm3"))))
-    ;; The package looks for Qt5LinguistTools provided by Qt, but apparently
-    ;; compiles without it; it might be needed for building the
-    ;; documentation, which requires the additional Sphinx package.
-    ;; To save space, we do not add these inputs.
+          "01m12ml529pwr2sal951r5z6yb1rwbpid1y4k14nlk3xqgmdakwa"))))
     (build-system cmake-build-system)
+    (native-inputs
+     `(("qtbase" ,qtbase))) ; For tests (needs qmake)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; install and check phase are swapped to prevent install from failing
+         ;; after testsuire has run
+         (add-after 'install 'check-post-install
+           (assoc-ref %standard-phases 'check))
+         (delete 'check))))
+    ;; optional dependencies - to save space, we do not add these inputs.
+    ;; Sphinx > 1.2:
+    ;;   Required to build Extra CMake Modules documentation in Qt Help format.
+    ;; Qt5LinguistTools , Qt5 linguist tools. , <http://www.qt.io/>
+    ;;   Required to run tests for the ECMPoQmTools module.
+    ;; Qt5Core
+    ;;   Required to run tests for the ECMQtDeclareLoggingCategory module,
+    ;;   and for some tests of the KDEInstallDirs module.
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "CMake module files for common software used by KDE")
     (description "The Extra CMake Modules package, or ECM, adds to the