summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-08 15:36:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-08 17:22:29 +0200
commit606c19878867ada90e40a46cf18194a0e1408945 (patch)
treef8d453c0b3e07d1ad0f6a028deb4837ec78e4ba1
parentb89284407fd5d865ca7cc8622459692cec9297cf (diff)
downloadguix-606c19878867ada90e40a46cf18194a0e1408945.tar.gz
gnu: crawl: Find all the included headers.
* gnu/packages/games.scm (crawl)[arguments]: Add a custom phase to
change the path for some headers.
-rw-r--r--gnu/packages/games.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9468802ea2..0d50f55a75 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4459,6 +4459,11 @@ fish.  The whole game is accompanied by quiet, comforting music.")
              (substitute* "source/Makefile"
                (("-mfpmath=sse -msse2") ""))
              #t))
+         (add-after 'unpack 'find-SDL-image
+           (lambda _
+             (substitute* "source/windowmanager-sdl.cc"
+               (("SDL_image.h") "SDL2/SDL_image.h"))
+             #t))
          (delete 'configure)
          (replace 'check
            (lambda* (#:key inputs outputs make-flags #:allow-other-keys)