summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-29 16:27:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-02 15:40:44 +0200
commit7035d2dd698a8a4af07894670bbc2f504089d2c7 (patch)
tree2bce62c6ca031f527d81ed10efca56712ef9eb9b
parent4028fd395e6d7f80f7bbeb4ff616b6b89b0bf654 (diff)
downloadguix-7035d2dd698a8a4af07894670bbc2f504089d2c7.tar.gz
gnu: libva: Update to 1.8.3.
GitHub is now the canonical distribution point of libva:
<https://github.com/01org/libva/issues/52#issuecomment-303465588>

* gnu/packages/video.scm (libva): Update to 1.8.3.
[source](uri): Add new download location.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4ce2a8f401..0ab6442d43 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -530,15 +530,19 @@ libebml is a C++ library to read and write EBML files.")
 (define-public libva
   (package
     (name "libva")
-    (version "1.8.2")
+    (version "1.8.3")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://www.freedesktop.org/software/vaapi/releases/libva/libva-"
-             version".tar.bz2"))
+       (uri (list
+             ;; Newer releases are only available on GitHub.
+             (string-append "https://github.com/01org/libva/releases/download/"
+                            version "/libva-" version ".tar.bz2")
+             ;; Keep the old URL around for compatibility.
+             (string-append "https://www.freedesktop.org/software/vaapi/releases/"
+                            "libva/libva-" version "/libva-" version ".tar.bz2")))
        (sha256
-        (base32 "1pnfl3q7dzxs26l3jk9xi97gr0qwnaz6dhvf9ifp2yplr3fy7lwy"))))
+        (base32 "16xbk0awl7wp0vy0nyjvxk11spbw25mp8kwd9bmhd6x9xffi5vjn"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))