summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-28 23:54:58 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-28 23:54:58 +0100
commit917748dd6d6237f7539e7d4a5bebb48551d91179 (patch)
tree725c4226a6e383bc54c792861dfbf1cec9b3cf64
parenta25fe6d62069ffaff276bf1747ab178441654f9d (diff)
downloadguix-917748dd6d6237f7539e7d4a5bebb48551d91179.tar.gz
gnu: xorg: Make most xserver related packages compile.
* gnu/packages/xorg.scm (xf86-*): Add input xorg-server.
* gnu/packages/xorg.scm (xf86-video-glint, xf86-video-neomagic,
     xf86-video-tga, xf86-video-trident, xf86-video-voodoo):
     Add input xf86dgaproto.
* gnu/packages/xorg.scm (xf86-video-ati, xf86-video-mach64,
     xf86-video-mga, xf86-video-r128, xf86-video-savage, xf86-video-tdfx):
     Add inputs mesa and xf86driproto.
* gnu/packages/xorg.scm (xf86-video-i128): Add inputs libdrm and libx11.
* gnu/packages/xorg.scm (xf86-video-openchrome): Add inputs libx11, libxext,
     libxvmc, mesa and xf86driproto.
* gnu/packages/xorg.scm (xf86-video-siliconmotion): Add inputs mesa,
     xf86dgaproto and xf86driproto.
* gnu/packages/xorg.scm (xf86-video-vmware): Add inputs libx11 and libxext.
* gnu/packages/xorg.scm (libxvmc): Propagate input libxv.
* gnu/packages/xorg.scm (mesa): Propagate input glproto.
* gnu/packages/xorg.scm (xf86-video-geode): Correct source hash.
-rw-r--r--gnu/packages/xorg.scm214
1 files changed, 143 insertions, 71 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 181aa6466f..bc5da3b7d5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1769,35 +1769,6 @@ and Matrox.")
     (license license:x11)))
 
 
-(define-public libxvmc
-  (package
-    (name "libxvmc")
-    (version "1.0.7")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/libXvMC-"
-               version
-               ".tar.bz2"))
-        (sha256
-          (base32
-            "18yf6ysc01pqkbk9704914ghalq1sl2hfdjmwggxm8qqhpy8bw18"))))
-    (build-system gnu-build-system)
-    (inputs
-      `(("libxv" ,libxv)
-        ("xproto" ,xproto)
-        ("xextproto" ,xextproto)
-        ("libxext" ,libxext)
-        ("libx11" ,libx11)
-        ("videoproto" ,videoproto)
-        ("pkg-config" ,pkg-config)))
-    (home-page "http://www.x.org/wiki/")
-    (synopsis "xorg implementation of the X Window System")
-    (description "X.org provides an implementation of the X Window System")
-    (license license:x11)))
-
-
 (define-public libxxf86dga
   (package
     (name "libxxf86dga")
@@ -2525,14 +2496,16 @@ and Matrox.")
           (base32
             "1ivf5n821chckrgp89mpb18zi00v1hyrkc1hr82q0x6g1kpgxq9y"))))
     (build-system gnu-build-system)
-    (inputs `(("xorg-server" ,xorg-server)
-              ("pkg-config" ,pkg-config)))
+    ;; FIXME: Add required input udev once it is available.
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
 
+;; FIXME: Tries to install file joystick-properties.h into ...--xorg-server-1.12.2/include/xorg
 (define-public xf86-input-joystick
   (package
     (name "xf86-input-joystick")
@@ -2548,7 +2521,8 @@ and Matrox.")
           (base32
             "1xgpkdmfw4ahjlva97gs9sllzw8nlpa8mxj59g28fxhak67mvv8x"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2570,7 +2544,8 @@ and Matrox.")
           (base32
             "1hwc1bjw5mxv186xbrxiky0agfglwqg8fsxqdh4br1vzgxpck7ma"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2592,7 +2567,8 @@ and Matrox.")
           (base32
             "0fs1lwnycyv3d0m6l2wrnlgvbs8qw66d93hwlnmrsswfq5bp6ark"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2614,13 +2590,16 @@ and Matrox.")
           (base32
             "0g5b1s6q1dg38l8y47cwg7cs5nivwj0agmp71g273ws0lfg4bc8s"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    ;; FIXME: Add required input mtdev.
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
 
+;; FIXME: Installation tries to create ...-xorg-server-1.12.2/share/X11/xorg.conf.d
 (define-public xf86-input-vmmouse
   (package
     (name "xf86-input-vmmouse")
@@ -2636,7 +2615,8 @@ and Matrox.")
           (base32
             "16l65mnjb1xxav6c5q0xhhqih81bzify2c5qrhqc2j3waq5yr9m8"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2658,7 +2638,8 @@ and Matrox.")
           (base32
             "01bmk324fq48wydvy1qrnxbw6qz0fjd0i80g0n4cqr1c4mjmif9a"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2680,7 +2661,8 @@ and Matrox.")
           (base32
             "194zc35ivfh3vcxcilf9nbi88c2di8kbh84x535cljlpiajdnk5x"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2702,7 +2684,8 @@ and Matrox.")
           (base32
             "1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2724,7 +2707,10 @@ and Matrox.")
           (base32
             "11gg6xn65vym75769hzgzpkjsyhlkrw4zw3ncngriq7vz1g47zjg"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xxf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2746,7 +2732,8 @@ and Matrox.")
           (base32
             "0blnbspj4936wy46lp346s4b08dfcray6yicsxvv5b4699fzl1rb"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2790,13 +2777,15 @@ and Matrox.")
           (base32
             "1mc23w0bfmak5216411xh58nrs93jlxmi6l412hmqzhxnjs73clk"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
 
+;; FIXME: Compilation errors
 (define-public xf86-video-geode
   (package
     (name "xf86-video-geode")
@@ -2810,15 +2799,17 @@ and Matrox.")
                ".tar.bz2"))
         (sha256
           (base32
-            "1mc23w0bfmak5216411xh58nrs93jlxmi6l412hmqzhxnjs73clk"))))
+            "09p2cjd2fb7h32k9qs4wp7qvhfn2zv454spv5mfplv7w2jis4863"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
 
+;; FIXME: Add required input "glide"
 (define-public xf86-video-glide
   (package
     (name "xf86-video-glide")
@@ -2834,7 +2825,8 @@ and Matrox.")
           (base32
             "0byapm9mnpqk3wijfnnan3d22ii5cw6dmg4xn1625iiz89j5vs1l"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2856,7 +2848,9 @@ and Matrox.")
           (base32
             "0nf36jryabpncqq4m6sfsnmzk00f7gvfmjnl8l8sfy7w6sa6iacs"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2878,7 +2872,8 @@ and Matrox.")
           (base32
             "1sik8ck410hb2885vy7rlc590hw5br8lr2fzxgmv55jyawgfpv9y"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2900,7 +2895,10 @@ and Matrox.")
           (base32
             "1g742szymajh88a5dw08sxcr45bmxgc4w3m6hddv9qscn5hks4rj"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libdrm" ,libdrm)
+              ("libx11" ,libx11)
+              ("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2922,7 +2920,10 @@ and Matrox.")
           (base32
             "0kl3kvpc2ny48z89313i9fi4cxzwb2pllvxcr9j5ly680ygx8slz"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2944,7 +2945,10 @@ and Matrox.")
           (base32
             "03l3wz5kz0hmxmzqqbkgn7pf9d956jlag04rb701a0fr1mw3v66a"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2966,7 +2970,9 @@ and Matrox.")
           (base32
             "124qci48xrk0w2jy91n7vqs7s6q397zyiqqszhmkx6ld7six57mi"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -2988,7 +2994,8 @@ and Matrox.")
           (base32
             "1yafmp23jrfdmc094i6a4dsizapsc9v0pl65cpc8w1kvn7343k4i"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3010,7 +3017,8 @@ and Matrox.")
           (base32
             "05glbi9jc7j9nm4sf4qvl3z87s48ibm3i283lqz85kbphg62dxvc"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3032,7 +3040,13 @@ and Matrox.")
           (base32
             "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libx11" ,libx11)
+              ("libxext" ,libxext)
+              ("libxvmc" ,libxvmc)
+              ("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3054,7 +3068,10 @@ and Matrox.")
           (base32
             "1c84x40k9qz9dnf5qs6nnjcgz7px6mpc3rbk8mj62zhp7mf16hbv"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3076,7 +3093,10 @@ and Matrox.")
           (base32
             "0jdy4wv3k3ylx3lajjcbsg37z2hf6366a1jvv16sv1ln6dk6lris"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3098,7 +3118,8 @@ and Matrox.")
           (base32
             "01sdl6ky1vmvmfgx2d44i35rqafi0z07xdy40cvindcr2k91p7x5"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3120,7 +3141,11 @@ and Matrox.")
           (base32
             "03diq0l93lfsipmwkpdb2ysgbxxryl6yakpghzc3fksjxa01112f"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3142,7 +3167,8 @@ and Matrox.")
           (base32
             "07w0hm63fiy5l3cpcjsl0ig8z84z9r36xm0cmnpiv3g75dy6q8fi"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3164,7 +3190,8 @@ and Matrox.")
           (base32
             "04byax4sc1fn183vyyq0q11q730k16h2by4ggjky7s36wgv7ldzx"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3186,7 +3213,10 @@ and Matrox.")
           (base32
             "124gsi30rj547jjd7gvv7xykfnwlyrxw0gcacamby7pvl3g33fg0"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("mesa" ,mesa)
+              ("pkg-config" ,pkg-config)
+              ("xf86driproto" ,xf86driproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3208,7 +3238,9 @@ and Matrox.")
           (base32
             "0mdqrn02zzkdnmhg4vh9djaawg6b2p82g5qbj66z8b30yr77b93h"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3230,7 +3262,9 @@ and Matrox.")
           (base32
             "02y5pzdp0a1c12jr8gghbrzgbyfbgq67x7kd7n4f323pmf8x1csb"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3274,7 +3308,8 @@ and Matrox.")
           (base32
             "0wqms28kkz2fvghqhqwp6w8zj7k5cgwnhzvkc7j4v268bf6h78g4"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3296,7 +3331,10 @@ and Matrox.")
           (base32
             "0isiwx516gww8hfk3vy7js83yziyjym9mq2zjadyq1a8v5gqf9y8"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libx11" ,libx11)
+              ("libxext" ,libxext)
+              ("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -3318,13 +3356,16 @@ and Matrox.")
           (base32
             "0ha748yz92yzn6hp2rhin3il8f4j2rs4vkgdvqkagnv1ryxkh0ph"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xf86dgaproto" ,xf86dgaproto)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
 
+;; FIXME: Add input providing dev/wscons/wsconsio.h; only relevant for BSD?
 (define-public xf86-video-wsfb
   (package
     (name "xf86-video-wsfb")
@@ -3340,7 +3381,8 @@ and Matrox.")
           (base32
             "0hr8397wpd0by1hc47fqqrnaw3qdqd8aqgwgzv38w5k3l3jy6p4p"))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("xorg-server" ,xorg-server)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -4273,6 +4315,36 @@ and Matrox.")
     (license license:x11)))
 
 
+(define-public libxvmc
+  (package
+    (name "libxvmc")
+    (version "1.0.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/X11R7.7/src/everything/libXvMC-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "18yf6ysc01pqkbk9704914ghalq1sl2hfdjmwggxm8qqhpy8bw18"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+      `(("libxv" ,libxv)))
+    (inputs
+      `(("xproto" ,xproto)
+        ("xextproto" ,xextproto)
+        ("libxext" ,libxext)
+        ("libx11" ,libx11)
+        ("videoproto" ,videoproto)
+        ("pkg-config" ,pkg-config)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "xorg implementation of the X Window System")
+    (description "X.org provides an implementation of the X Window System")
+    (license license:x11)))
+
+
 (define-public mkfontdir
   (package
     (name "mkfontdir")
@@ -4345,13 +4417,13 @@ and Matrox.")
             "0pjs8x51c0i6mawgd4w03lxpyx5fnx7rc8plr8jfsscf9yiqs6si"))))
     (build-system gnu-build-system)
     (propagated-inputs
-      `(("libdrm" ,libdrm-2.4.33)
+      `(("glproto" ,glproto)
+        ("libdrm" ,libdrm-2.4.33)
         ("libxdamage" ,libxdamage)))
     (inputs
       `(("bison" ,bison)
         ("dri2proto" ,dri2proto)
         ("expat" ,expat)
-        ("glproto" ,glproto)
         ("flex" ,flex)
         ("libx11" ,libx11)
         ("libxext" ,libxext)
@@ -4629,8 +4701,8 @@ emulation to complete hardware acceleration for modern GPUs.")
 ;;        ("xkeyboard-config" ,xkeyboard-config)
         ("xtrans" ,xtrans)
         ("zlib" ,zlib)))
-;;     (arguments
-;;      `(#:tests? #f))
+    (arguments
+     `(#:tests? #f))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")