summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-07-04 18:11:30 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-07-04 18:11:30 +0530
commit948e888d3a35d88fe7a972a21f47f60ec5e4279b (patch)
tree0abd71de7f68afc0409918be7f363c1772744b60
parentd88b29d6b78482cdb05ac714984f6a27195e3d37 (diff)
downloadguix-948e888d3a35d88fe7a972a21f47f60ec5e4279b.tar.gz
gnu: ledger: Skip failing test.
* gnu/packages/finance.scm (ledger)[arguments]: Set #:make-flags to skip
failing test BaselineTest_cmd-org. Replace check phase with the check phase
from gnu-build-system.
-rw-r--r--gnu/packages/finance.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e69b3cabc4..3eab2fa14d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -142,6 +143,7 @@ line client and a client based on Qt.")
     (build-system cmake-build-system)
     (arguments
      `(#:modules ((guix build cmake-build-system)
+                  ((guix build gnu-build-system) #:prefix gnu:)
                   (guix build utils)
                   (guix build emacs-utils))
        #:imported-modules (,@%cmake-build-system-modules
@@ -155,6 +157,10 @@ line client and a client based on Qt.")
          ,(string-append "-DUTFCPP_INCLUDE_DIR:PATH="
                          (assoc-ref %build-inputs "utfcpp")
                          "/include"))
+       ;; Skip failing test BaselineTest_cmd-org during the check phase.
+       ;; This is a known upstream issue. See
+       ;; https://github.com/ledger/ledger/issues/550
+       #:make-flags (list "ARGS=-E BaselineTest_cmd-org")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'install-examples
@@ -173,6 +179,7 @@ line client and a client based on Qt.")
                      (string-append (assoc-ref inputs "tzdata")
                                     "/share/zoneinfo"))
              #t))
+         (replace 'check (assoc-ref gnu:%standard-phases 'check))
          (add-after 'install 'relocate-elisp
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((site-dir (string-append (assoc-ref outputs "out")