summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-12 10:35:44 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-14 18:26:25 +0100
commit97c26793d94fe95c51de21fd98bc5cab2f1425a7 (patch)
tree8d30493d1a69ce3c2885d64701f314510d5cb6ad
parent8a6cd65a2a66107b5a1ae12138a9af0002f55983 (diff)
downloadguix-97c26793d94fe95c51de21fd98bc5cab2f1425a7.tar.gz
gnu: Add python2-pyopengl-accelerate.
* gnu/packages/python.scm (python2-pyopengl-accelerate): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 01b4e2cd29..e36056d454 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11523,6 +11523,22 @@ related APIs.  The binding is created using the standard @code{ctypes}
 library.")
    (license license:bsd-3)))
 
+(define-public python2-pyopengl-accelerate
+  (package
+    (inherit python2-pyopengl)
+    (name "python2-pyopengl-accelerate")
+    (version "3.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyOpenGL-accelerate" version))
+       (sha256
+        (base32
+         "0464c1ifzk0k92lyndikmvzjgnx1y25r7bkkc8pnxm4kp1q4czwj"))))
+    (synopsis "Acceleration code for PyOpenGL")
+    (description
+     "This is the Cython-coded accelerator module for PyOpenGL.")))
+
 (define-public python-rencode
   (package
    (name "python-rencode")