summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-08 15:27:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-08 17:22:29 +0200
commitb89284407fd5d865ca7cc8622459692cec9297cf (patch)
treef0afbcfddd5eeb7d001029b7e8fbcaae73d75445
parentfc7d6bc60d0ee85017217b528cb2f46342141c11 (diff)
downloadguix-b89284407fd5d865ca7cc8622459692cec9297cf.tar.gz
gnu: crawl: Don't assume system architecture.
This allows crawl to build on non-Intel architectures.

* gnu/packages/games.scm (crawl)[arguments]: Add a custom phase to
remove x86* specific CFLAGS.
-rw-r--r--gnu/packages/games.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1742454729..9468802ea2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4454,6 +4454,11 @@ fish.  The whole game is accompanied by quiet, comforting music.")
                "-Csource"))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-flags
+           (lambda _
+             (substitute* "source/Makefile"
+               (("-mfpmath=sse -msse2") ""))
+             #t))
          (delete 'configure)
          (replace 'check
            (lambda* (#:key inputs outputs make-flags #:allow-other-keys)