summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:23:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:23:20 +0300
commit0d6fffc5fd8f37b5b49220f67c39548108768b60 (patch)
tree7e16a60fe1c383a07c44af2ac9624afca6aaed12
parent83dd7825187fc533aeadc2113b70c704e1968e56 (diff)
downloadguix-0d6fffc5fd8f37b5b49220f67c39548108768b60.tar.gz
gnu: Add python-lazr-delegates.
* gnu/packages/python-xyz.scm (python-delegates): New variable.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8af77ad3ac..db05a52d14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20650,3 +20650,34 @@ files into HTML.  It is designed to be used in Warehouse to render the
 @code{long_description} for packages.  It can handle Markdown, reStructuredText,
 and plain text.")
     (license license:asl2.0)))
+
+(define-public python-lazr-delegates
+  (package
+    (name "python-lazr-delegates")
+    (version "2.0.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "lazr.delegates" version))
+        (sha256
+         (base32
+          "1rdnl85j9ayp8n85l0ciip621j9dcziz5qnmv2m7krgwgcn31vfx"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "setup.py" "nosetests"))))))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-zope-interface" ,python-zope-interface)))
+    (home-page "https://launchpad.net/lazr.delegates")
+    (synopsis "Easily write objects that delegate behavior")
+    (description
+     "The @code{lazr.delegates} package makes it easy to write objects that
+delegate behavior to another object.  The new object adds some property or
+behavior on to the other object, while still providing the underlying interface,
+and delegating behavior.")
+    (license license:lgpl3)))