summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-16 16:47:07 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-16 16:48:25 +0200
commit2020a0567b469aee0e975583aa39f4b51a976120 (patch)
treef4504e3f213e45617e9ae34bbe5666cff0c9ec99
parentd57ce2024b0bdec0f8d05258c32c7bc7275a17a6 (diff)
downloadguix-2020a0567b469aee0e975583aa39f4b51a976120.tar.gz
gnu: Add cl-tga.
* gnu/packages/lisp-xyz.scm (sbcl-tga, cl-tga, ecl-tga): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 04c7c3e9ca..f0e4189b13 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12295,3 +12295,33 @@ convolutions, etc.")
 
 (define-public cl-napa-fft3
   (sbcl-package->cl-source-package sbcl-napa-fft3))
+
+(define-public sbcl-cl-tga
+  (let ((commit "4dc2f7b8a259b9360862306640a07a23d4afaacc")
+        (revision "0"))
+    (package
+      (name "sbcl-cl-tga")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/fisxoj/cl-tga")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "03k3npmn0xd3fd2m7vwxph82av2xrfb150imqrinlzqmzvz1v1br"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/fisxoj/cl-tga")
+      (synopsis "TGA file loader for Common Lisp")
+      (description
+       "Cl-tga was written to facilitate loading @emph{.tga} files into OpenGL
+programs.  It's a very simple library, and, at the moment, only supports
+non-RLE encoded forms of the files.")
+      (license license:expat))))
+
+(define-public cl-tga
+  (sbcl-package->cl-source-package sbcl-cl-tga))
+
+(define-public ecl-cl-tga
+  (sbcl-package->ecl-package sbcl-cl-tga))