summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-17 03:30:28 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 19:04:07 +0200
commit215e68ec60204db0b45df45c5d951f728a1b5657 (patch)
tree906fcc9549e50788731570add98dcc30eb42230b
parent2b5b57daca6ce73032eb2b5c7916b3796eee7d4f (diff)
downloadguix-215e68ec60204db0b45df45c5d951f728a1b5657.tar.gz
gnu: eog: Remove custom typelib wrap.
* gnu/packages/gnome.scm (eog) [arguments]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 35f4a83ed1..271e6e5937 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7287,14 +7287,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
                (rename-file
                 (string-append out "/share/help")
                 (string-append help "/share/help"))
-               #t)))
-         (add-after 'move-help 'wrap-eog
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
-               (wrap-program (string-append out "/bin/eog")
-                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
-             #t)))))
+               #t))))))
     (native-inputs
      `(("docbook-xml" ,docbook-xml-4.1.2)
        ("glib" ,glib "bin")