summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-09 07:32:10 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 19:04:02 +0200
commit33f6379d0144e4d5e109fbe7aa0f5e8bac263ace (patch)
tree167f5d8e04a98f2655e0746cc3d133b68ad6fa4f
parent84fde8ab7aee4502f57d553f4b2014aab3f64afa (diff)
downloadguix-33f6379d0144e4d5e109fbe7aa0f5e8bac263ace.tar.gz
gnu: wayland-protocols: Update package definition.
* gnu/packages/freedesktop.scm (wayland-protocols) [version]: Update
to 1.20.
[source]<origin>[sha256]: Modify base32.
[description]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/freedesktop.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d986e7aec8..d8d58be97e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -830,22 +830,26 @@ fullscreen) or other display servers.")
 (define-public wayland-protocols
   (package
     (name "wayland-protocols")
-    (version "1.18")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://wayland.freedesktop.org/releases/"
-                    "wayland-protocols-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1cvl93h83ymbfhb567jv5gzyq08181w7c46rsw4xqqqpcvkvfwrx"))))
+    (version "1.20")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://wayland.freedesktop.org/releases/"
+         "wayland-protocols-" version ".tar.xz"))
+       (sha256
+        (base32 "1rsdgvkkvxs3cjhpl6agvbkm53vm7k8rg127j9y2vn33m2hvg0lp"))))
     (build-system gnu-build-system)
-    (inputs
-     `(("wayland" ,wayland)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("wayland" ,wayland)))
     (synopsis "Wayland protocols")
-    (description "This package contains XML definitions of the Wayland protocols.")
+    (description "Wayland-Protocols contains Wayland protocols that add
+functionality not available in the Wayland core protocol.  Such protocols either
+add completely new functionality, or extend the functionality of some other
+protocol either in Wayland core, or some other protocol in wayland-protocols.")
     (home-page "https://wayland.freedesktop.org")
     (license license:expat)))