summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-26 17:03:50 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-29 09:12:20 +0200
commit4389cccb7f9f70e8a7c1b78b9d055b652ab9f905 (patch)
tree4bbcfb234b060ce074961f629417110514cbebd0
parent713766febf2c50b8bb5aa342ede23322e4d6ec27 (diff)
downloadguix-4389cccb7f9f70e8a7c1b78b9d055b652ab9f905.tar.gz
gnu: gnome-maps: Fix launching of the application and loading of icons.
* gnu/packages/geo.scm (gnome-maps) [inputs]: Add gfbgraph, gsettings-desktop-schemas,
libgweather and webkitgtk.
[propagated-inputs]: Add dconf.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b22a0233c6..1a94b10079 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -240,12 +240,18 @@ topology functions.")
        ("gee" ,libgee)
        ("geoclue" ,geoclue)
        ("geocode-glib" ,geocode-glib)
+       ("gfbgraph" ,gfbgraph)
        ("gjs" ,gjs)
        ("glib" ,glib)
        ("glib-networking" ,glib-networking)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
+       ("gweather" ,libgweather)
        ("libxml2" ,libxml2)
-       ("rest" ,rest)))
+       ("rest" ,rest)
+       ("webkitgtk" ,webkitgtk)))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
     (synopsis "Map application for GNOME")
     (description "GNOME-Maps gives you quick access to maps all across the
 world.  It uses the collaborative OpenStreetMap database, enabling users to make