summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-30 02:09:47 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-30 10:48:36 +0200
commit7341dee7f92a7361869dff175b37dc557be2430a (patch)
tree54ebf5f1c9166116e69027eddc016ff638cc9dd9
parent19368c17c3241380bd5f8f18f3b64f6bc0695849 (diff)
downloadguix-7341dee7f92a7361869dff175b37dc557be2430a.tar.gz
gnu: webkitgtk: Fix bubblewrap.
* gnu/packages/webkit.scm (webkitgtk) [arguments]<#:phases>['configure-bubblewrap]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 4fc1b7c7dc..28dbaad3ea 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -265,6 +265,15 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                                   "/xml/dtd/docbook/docbookx.dtd"))))
               (find-files "Source" "\\.sgml$"))
              #t))
+         (add-before 'configure 'configure-bubblewrap
+           (lambda _
+             ;; This phase is a corollary to 'webkitgtk-share-store.patch' to
+             ;; avoid hard coding /gnu/store, for users with other prefixes.
+             (let ((store-directory (%store-directory)))
+               (substitute*
+                   "Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp"
+                 (("@storedir@") store-directory))
+               #t)))
          (add-after 'install 'move-doc-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))