summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-17 03:35:18 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 19:04:08 +0200
commit9e5d8e438e68ce3c8a6b641429924254af0c7e73 (patch)
treeae2c5d58a156a4dff0acc866d8e2b4c973b89076
parentd2c0c3c0d7a1a05348565f973ce0addb22e9f1e5 (diff)
downloadguix-9e5d8e438e68ce3c8a6b641429924254af0c7e73.tar.gz
gnu: gedit: Replace custom typelib and python wraps.
* gnu/packages/gnome.scm (gedit) [arguments]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1f3c4e9b20..aa700022d6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8281,6 +8281,7 @@ spidermonkey javascript engine and the GObject introspection framework.")
     (outputs '("out" "help" "doc"))
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
+       #:python? #t ; To wrap binaries
        #:configure-flags
        (list
         "-Dgtk_doc=true"
@@ -8338,13 +8339,8 @@ spidermonkey javascript engine and the GObject introspection framework.")
          (add-after 'move-help 'wrap-gedit
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
-                    (gtksourceview (assoc-ref inputs "gtksourceview"))
-                    (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
-                    (python-path (getenv "PYTHONPATH")))
+                    (gtksourceview (assoc-ref inputs "gtksourceview")))
                (wrap-program (string-append out "/bin/gedit")
-                 ;; For plugins.
-                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
-                 `("PYTHONPATH" ":" prefix (,python-path))
                  ;; For language-specs.
                  `("XDG_DATA_DIRS" ":" prefix (,(string-append gtksourceview
                                                                "/share")))))