summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-01 23:52:30 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-02 15:05:57 +0200
commitb05722c23d0433a0f0c98f5e99ebed86027092c1 (patch)
treefac4868b97bef807d7db796d6d2cbfed8cc98703
parent769f4ea088a5ea41c5c2ecb4bfc2a6f7104037f0 (diff)
downloadguix-b05722c23d0433a0f0c98f5e99ebed86027092c1.tar.gz
gnu: gnome-terminal: Fix launching of the application.
* gnu/packages/gnome.scm (gnome-terminal) [inputs]: Move dconf to ...
[propagated-inputs]: ... here.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fb0d9c3358..1b8f221dbc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5699,8 +5699,7 @@ more fun.")
        ("vala" ,vala)
        ("xmllint" ,libxml2)))
     (inputs
-     `(("dconf" ,dconf)
-       ("glib" ,glib)
+     `(("glib" ,glib)
        ("gnome-shell-search-provider" ,gnome-shell)
        ("gtk+" ,gtk+)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -5708,6 +5707,8 @@ more fun.")
        ("libpcre2" ,pcre2)
        ("util-linux" ,util-linux "lib")
        ("vte" ,vte)))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
     (synopsis "Terminal emulator")
     (description "GNOME-Terminal is a terminal emulator for GNOME.")
     (home-page "https://wiki.gnome.org/Apps/Terminal")