summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-26 12:01:47 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-29 09:12:19 +0200
commitda548cacfc531275ac47ef6c1624463c749799b8 (patch)
tree7c95c2d3ca05a4e9205d7cbb429d0f9b1cc1234a
parent1a66699721a93c5cb57fb9af1bc8efbd1a919780 (diff)
downloadguix-da548cacfc531275ac47ef6c1624463c749799b8.tar.gz
gnu: epiphany: Fix loading of icons.
* gnu/packages/gnome.scm (epiphany) [version]: Update to 3.36.4.
[propagated-inputs]: Add dconf.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 59d2f0eb33..9a025711ee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7622,7 +7622,7 @@ a secret password store, an adblocker, and a modern UI.")
 (define-public epiphany
   (package
     (name "epiphany")
-    (version "3.36.3")
+    (version "3.36.4")
     (source
      (origin
        (method url-fetch)
@@ -7631,7 +7631,7 @@ a secret password store, an adblocker, and a modern UI.")
                        (version-major+minor version) "/"
                        "epiphany-" version ".tar.xz"))
        (sha256
-        (base32 "0vz1j6yrjv0nmf5lk8prkkm10fbcmd35khy9zsd7d4a86wk5c6v2"))))
+        (base32 "1gs2a94fzpciv58rljgbirsc2kqgiaiyc2yg6ff50nlgb2qpb2jq"))))
     (build-system meson-build-system)
     (outputs '("out" "help"))
     (arguments
@@ -7705,6 +7705,8 @@ a secret password store, an adblocker, and a modern UI.")
        ("nettle" ,nettle)
        ("sqlite" ,sqlite)
        ("webkitgtk" ,webkitgtk)))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
     (synopsis "GNOME web browser")
     (description "Epiphany is a GNOME web browser based on the WebKit rendering
 engine.")