summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-09 22:51:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-20 01:49:34 +0200
commite1f640db8fa2a3aee018ce80df47b37e245c4b52 (patch)
tree7271c65d40c66bbff2509706e36d2a652b2ec550
parent99568122374b1e119838a08e6fed2f6eeef5d493 (diff)
downloadguix-e1f640db8fa2a3aee018ce80df47b37e245c4b52.tar.gz
gnu: Move Linux-Libre modules to their own section.
* gnu/packages/linux.scm (vhba-module): Move to its own section.
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59cb1e6d05..08389e2590 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -559,6 +559,33 @@ between the CDemu userspace daemon and linux kernel.")
 
 
 ;;;
+;;; Linux kernel modules.
+;;;
+
+(define-public vhba-module
+  (package
+    (name "vhba-module")
+    (version "20190410")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
+    (build-system linux-module-build-system)
+    (arguments
+     ;; TODO: No tests?
+     `(#:tests? #f))
+    (home-page "https://cdemu.sourceforge.io/")
+    (synopsis "Kernel module that emulates SCSI devices")
+    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+    (license license:gpl2+)))
+
+
+;;;
 ;;; Pluggable authentication modules (PAM).
 ;;;