summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 12:23:33 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-03 14:36:11 +0200
commite393586161dd0b8814bbb88e9212deffa171687f (patch)
tree8290cb45f5ddd4158323d164ed032a2d1c702f82
parent2ae71b746bd7265735cb50b2dd93a09ef45f9f38 (diff)
downloadguix-e393586161dd0b8814bbb88e9212deffa171687f.tar.gz
gnu: coreutils: Use upstream's fix for 'tail'.
* gnu/packages/patches/coreutils-racy-tail-test.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
* gnu/packages/base.scm (coreutils)[source]: Replace this patch with
  upstream's fix for 'tail'.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/base.scm9
-rw-r--r--gnu/packages/patches/coreutils-racy-tail-test.patch13
3 files changed, 8 insertions, 15 deletions
diff --git a/gnu-system.am b/gnu-system.am
index fbfe72845b..faf42b757e 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -418,7 +418,6 @@ dist_patch_DATA =						\
   gnu/packages/patches/clang-libc-search-path.patch		\
   gnu/packages/patches/clucene-pkgconfig.patch			\
   gnu/packages/patches/cmake-fix-tests.patch			\
-  gnu/packages/patches/coreutils-racy-tail-test.patch		\
   gnu/packages/patches/cpio-gets-undeclared.patch		\
   gnu/packages/patches/cpufrequtils-fix-aclocal.patch		\
   gnu/packages/patches/crda-optional-gcrypt.patch		\
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 99f60d1400..1b4233420f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -251,7 +251,14 @@ used to apply commands with arbitrarily long arguments.")
              (base32
               "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
             (patches
-             (list (search-patch "coreutils-racy-tail-test.patch")))))
+             (list (origin
+                     (method url-fetch)
+                     (uri "http://git.savannah.gnu.org/cgit/coreutils.git/\
+patch/?id=3ba68f9e64fa2eb8af22d510437a0c6441feb5e0")
+                     (sha256
+                      (base32
+                       "1dnlszhc8lihhg801i9sz896mlrgfsjfcz62636prb27k5hmixqz"))
+                     (file-name "coreutils-tail-inotify-race.patch"))))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)                        ;bignums in 'expr', yay!
diff --git a/gnu/packages/patches/coreutils-racy-tail-test.patch b/gnu/packages/patches/coreutils-racy-tail-test.patch
deleted file mode 100644
index 91640513e4..0000000000
--- a/gnu/packages/patches/coreutils-racy-tail-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Skip this test, which uncovers a race condition in how 'tail' handles
-file deletion.  See <http://bugs.gnu.org/21460>.
-
---- a/tests/tail-2/assert.sh
-+++ b/tests/tail-2/assert.sh
-@@ -16,6 +16,7 @@
- # You should have received a copy of the GNU General Public License
- # along with this program.  If not, see <http://www.gnu.org/licenses/>.
- 
-+exit 77				# see <http://bugs.gnu.org/21460>
- 
- # This test fails with tail from textutils-2.0.
- # It would get something like this: