summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-25 12:57:40 +0200
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:55 +0200
commitedce3b955d4acd0e94a2bb05a4241bb75b545330 (patch)
tree8de66bdf7b72e8b858ffd57cae1e426eb92437af
parent406f3f9b8afe77823b11932586e32e259f1b9242 (diff)
downloadguix-edce3b955d4acd0e94a2bb05a4241bb75b545330.tar.gz
gnu: procenv: Check is a native input.
* gnu/packages/linux.scm (procenv)[inputs]: Move CHECK ...
[native-inputs]: ... here.
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6f98277c89..ea47a8f371 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6420,12 +6420,16 @@ the MTP device as a file system.")
       (base32 "1ilrsw1rc85w29mkbkmm5n5w427gapv43yrjzvkb4kc9xhscgdjn"))))
    (build-system gnu-build-system)
    (arguments `(#:configure-flags '("--disable-silent-rules")))
-   (native-inputs `(("groff" ,groff) ; for tests
-                    ("pkg-config" ,pkg-config)))
-   (inputs `(("check" ,check)
-             ("expat" ,expat)
-             ("libcap" ,libcap)
-             ("libselinux" ,libselinux)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)
+
+      ;; For tests.
+      ("check" ,check)
+      ("groff" ,groff)))
+   (inputs
+    `(("expat" ,expat)
+      ("libcap" ,libcap)
+      ("libselinux" ,libselinux)))
    (synopsis "Utility to show process environment")
    (description "Procenv is a command-line tool that displays as much detail about
 itself and its environment as possible.  It can be used as a test