summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-03 08:22:11 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:37 +0200
commit0960bf8b3976dcdc9554c288d16d229bc145ea8f (patch)
treeacf82ee0934abf55843998d63f8a2d5ced49443f
parent7d88093f421b48ce5c13e389d7734462da7de4b5 (diff)
downloadguix-0960bf8b3976dcdc9554c288d16d229bc145ea8f.tar.gz
gnu: Add python-validate-email.
* gnu/packages/python.scm (python-validate-email, python2-validate-email):
New variables.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index df9503e38f..8adf658f7e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15121,3 +15121,24 @@ validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")
 
 (define-public python2-rfc3987
   (package-with-python2 python-rfc3987))
+
+(define-public python-validate-email
+  (package
+    (name "python-validate-email")
+    (version "1.3")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "validate_email" version))
+      (sha256
+       (base32
+        "1bxffaf5yz2cph8ki55vdvdypbwkvn2xr1firlcy62vqbzf1jivq"))))
+    (build-system python-build-system)
+    (home-page "http://github.com/syrusakbary/validate_email")
+    (synopsis "Verifies if an email address is valid and really exists")
+    (description "@code{validate_email} can be used to verify if an email
+address is valid and really exists.")
+    (license license:lgpl3+)))
+
+(define-public python2-validate-email
+  (package-with-python2 python-validate-email))