summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-25 14:48:45 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-25 14:50:56 +0200
commite7ab9c33cca6acf1fe25d192820ae59aa2082fcb (patch)
treef581d79251c67aef2ceb2cef77890fab0233bce5
parent0e54d63dfa60bb729a844a182001631967e8a8c3 (diff)
downloadguix-e7ab9c33cca6acf1fe25d192820ae59aa2082fcb.tar.gz
gnu: gnutls: Enable more testing.
* gnu/packages/tls.scm (gnutls)[native-inputs]: Add NET-TOOLS, IPROUTE,
and SOCAT.
[arguments]: Adjust #:disallowed-references accordingly.
-rw-r--r--gnu/packages/tls.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 8e2fc13c77..74cd17f8e8 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -61,6 +61,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nettle)
+  #:use-module (gnu packages networking)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -183,8 +184,11 @@ living in the same process.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? ,(not (hurd-target?))
-       ;; Ensure we don't keep a reference to net-tools.
-       #:disallowed-references ,(if (hurd-target?) '() (list net-tools))
+
+       ;; Ensure we don't keep a reference to the tools used for testing.
+       #:disallowed-references ,(if (hurd-target?)
+                                    '()
+                                    (list net-tools iproute socat))
        #:configure-flags
        (list
              ;; GnuTLS doesn't consult any environment variables to specify
@@ -236,12 +240,16 @@ living in the same process.")
                "debug"
                "doc"))                            ;4.1 MiB of man pages
     (native-inputs
-     `(,@(if (hurd-target?) '()
-             `(("net-tools" ,net-tools)))
+     `(,@(if (hurd-target?)
+             '()
+             `(("net-tools" ,net-tools)
+               ("iproute" ,iproute)               ;for 'ss'
+               ("socat" ,socat)))                 ;several tests rely on it
        ("autoconf" ,autoconf)
        ("automake" ,automake)
        ("gettext" ,gettext-minimal)
        ("libtool" ,libtool)
+
        ("pkg-config" ,pkg-config)
        ("texinfo" ,texinfo)
        ("which" ,which)