summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-25 15:15:59 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-25 15:15:59 +0200
commit0b40d1a3b414857e708944f821f250098cb9c125 (patch)
tree12fd8866fed3e6ef1295759f614f23a773e83ab2
parente7ab9c33cca6acf1fe25d192820ae59aa2082fcb (diff)
downloadguix-0b40d1a3b414857e708944f821f250098cb9c125.tar.gz
gnu: gnutls: Remove dependency on the Autotools.
This is a followup to 5cf6f6fe7b610e50d4f723f345799092d2b518ba.

* gnu/packages/tls.scm (gnutls)[arguments]: In 'disable-failing-tests'
phase, change 'tests/fastopen.sh' instead of 'tests/Makefile.am'.
[native-inputs]: Remove AUTOCONF, AUTOMAKE, GETTEXT-MINIMAL, and
LIBTOOL.
-rw-r--r--gnu/packages/tls.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 74cd17f8e8..510f0571c1 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -46,13 +46,11 @@
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
-  #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages dns)
   #:use-module (gnu packages gawk)
-  #:use-module (gnu packages gettext)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages hurd)
   #:use-module (gnu packages libbsd)
@@ -221,9 +219,9 @@ living in the same process.")
                   ;; https://gitlab.com/gnutls/gnutls/-/issues/1095).
                   (add-after 'unpack 'disable-failing-tests
                     (lambda _
-                      (delete-file "configure")
-                      (substitute* "tests/Makefile.am"
-                        (("fastopen.sh") ""))
+                      (substitute* "tests/fastopen.sh"
+                        (("^unset RETCODE")
+                         "exit 77\n"))            ;skip
                       #t))
                   (add-after 'install 'move-doc
                    (lambda* (#:key outputs #:allow-other-keys)
@@ -245,11 +243,6 @@ living in the same process.")
              `(("net-tools" ,net-tools)
                ("iproute" ,iproute)               ;for 'ss'
                ("socat" ,socat)))                 ;several tests rely on it
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext" ,gettext-minimal)
-       ("libtool" ,libtool)
-
        ("pkg-config" ,pkg-config)
        ("texinfo" ,texinfo)
        ("which" ,which)