summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-09-10 02:45:43 +0100
committerLudovic Courtès <ludo@gnu.org>2020-09-10 11:57:11 +0200
commit1bec03df9b60f156c657a64a323ef27f4ed14b44 (patch)
tree155d585e2ca04ac791ad1422f89089801a9e4ed6
parent24ce6e27bffd0f5574924d53a289743fa944c16a (diff)
downloadguix-1bec03df9b60f156c657a64a323ef27f4ed14b44.tar.gz
gnu: meson: Update to 0.55.1.
* gnu/packages/build-tools.scm (meson): Update to 0.55.1.
* gnu/packages/patches/meson-for-build-rpath.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/build-tools.scm7
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch24
3 files changed, 3 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c9ab3f203b..9bb0696b2b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1300,7 +1300,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/mediastreamer2-srtp2.patch		\
   %D%/packages/patches/mesa-skip-disk-cache-test.patch		\
   %D%/packages/patches/mescc-tools-boot.patch			\
-  %D%/packages/patches/meson-for-build-rpath.patch		\
   %D%/packages/patches/metabat-fix-compilation.patch		\
   %D%/packages/patches/mhash-keygen-test-segfault.patch		\
   %D%/packages/patches/mingw-w64-6.0.0-gcc.patch		\
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 7213c1bd0b..c3bb3042a6 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -179,7 +179,7 @@ files and generates build instructions for the Ninja build system.")
 (define-public meson
   (package
     (name "meson")
-    (version "0.53.2")
+    (version "0.55.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mesonbuild/meson/"
@@ -187,7 +187,7 @@ files and generates build instructions for the Ninja build system.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "07y2hh9dfn1m9g4bsy49nbn3vdmd0b2iwr8bxg19fhqq6c7q73ry"))))
+                "1070kjiirxxdfppmrhi3wsc6rykay1zlciqrzayjhjg0hkw42mrv"))))
     (build-system python-build-system)
     (arguments
      `(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
@@ -216,8 +216,7 @@ resembles Python.")
     (inherit meson)
     (name "meson-for-build")
     (source (origin
-              (inherit (package-source meson))
-              (patches (search-patches "meson-for-build-rpath.patch"))))
+              (inherit (package-source meson))))
 
     ;; People should probably install "meson", not "meson-for-build".
     (properties `((hidden? . #t)))))
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
deleted file mode 100644
index ef9a73f07c..0000000000
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This patch removes a part of meson that clears the rpath upon installation.
-This will only be applied to a special version of meson, used for the
-meson-build-system.
-
-Original patch for Meson 0.42.0 by Peter Mikkelsen <petermikkelsen10@gmail.com>
-
---- meson-0.47.1/mesonbuild/minstall.py.old	2018-08-10 11:01:27.812327013 +0200
-+++ meson-0.47.1/mesonbuild/minstall.py	2018-08-10 11:01:51.940368505 +0200
-@@ -436,15 +436,6 @@
-                         print("Symlink creation does not work on this platform. "
-                               "Skipping all symlinking.")
-                         printed_symlink_error = True
--            if os.path.isfile(outname):
--                try:
--                    depfixer.fix_rpath(outname, install_rpath, final_path,
--                                       install_name_mappings, verbose=False)
--                except SystemExit as e:
--                    if isinstance(e.code, int) and e.code == 0:
--                        pass
--                    else:
--                        raise
- 
- def run(args):
-     parser = buildparser()