summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-06 16:55:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-06 16:55:12 +0200
commit416fe466a6b4621264387751f3ca65533bc2915a (patch)
treefddda4e58a4da94fdae07621145ad404d7f6c6a5
parent39b8e41927b1f4e91560a781a039ca36c52a68f3 (diff)
downloadguix-416fe466a6b4621264387751f3ca65533bc2915a.tar.gz
gnu: ode: Update to 0.16.2.
* gnu/packages/game-development.scm (ode): Update to 0.16.2.
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b0a25ae7b4..4740546dbe 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2127,14 +2127,14 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
 (define-public ode
   (package
     (name "ode")
-    (version "0.16.1")
+    (version "0.16.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://bitbucket.org/odedevs/ode/downloads/"
                            "ode-" version ".tar.gz"))
        (sha256
-        (base32 "1flfdqgdbcn1bx8nrrd4qnp6cvsxrhvk8cdg7vaq2dzkh6nsqa5j"))
+        (base32 "08hgh4gqdk77jcw8b7gq2mwsfg4a5v5y0j7g42bxiqhmn3ffnsmj"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -2142,12 +2142,7 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
            #t))))
     (build-system cmake-build-system)
     (arguments
-     ;; Tests fail on all systems but x86_64.  This is fixed upstream and can
-     ;; be removed in 0.16.2+.
-     `(#:tests? ,(string-prefix? "x86_64-"
-                                 (or (%current-target-system)
-                                     (%current-system)))
-       #:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
+     `(#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'unbundle-libccd