summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-07 20:26:19 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-07 20:26:19 -0500
commit5b73b22bb1c49039518eb3c8ed570f22b16174b7 (patch)
treed7a3bb3a0ddb7ea8a1886129e850c4133582085d
parent93538a0a5bdf27091f0e19929bb05d418143027f (diff)
downloadguix-5b73b22bb1c49039518eb3c8ed570f22b16174b7.tar.gz
gnu: Add emacs-highlight.
* gnu/packages/emacs-xyz.scm (emacs-highlight): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 15edfc753d..6dbe6025ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24140,3 +24140,28 @@ you use some other configuration.")
 read-only, constant database that maps Emacs Lisp symbols to
 arbitrary Emacs Lisp objects.")
     (license license:gpl3+)))
+
+(define-public emacs-highlight
+  (let ((commit "9258a2b8362d737115cbd87618f947eadb140411")
+        (revision "1"))
+    (package
+      (name "emacs-highlight")
+      (version "0.0.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsmirror/highlight/")
+               (commit commit)))
+         (file-name (git-file-name name commit))
+         (sha256
+          (base32
+           "0pbqzgbfkm8smi23j94hirxh2r1yc0ipyjbbv1y906br6bx5c1a8"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacsmirror/highlight")
+      (synopsis "Highlighting commands for GNU Emacs")
+      (description "This library adds the possibility for ad-hoc
+applying highlighting to any face in GNU Emacs.  The functionality
+of this library depends on overlays, which by default are not
+picked up when copy-pasting text from buffer to buffer.")
+      (license license:gpl2+))))