summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-07 20:26:54 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-07 20:26:54 -0500
commit99c5f00b3699b94c114b5447e11a914684cb376e (patch)
tree808d406730c540287d290b36a0f9420856ff2f88
parent1218114e0d56c8f73da78bc04d0b5caf02c6b784 (diff)
downloadguix-99c5f00b3699b94c114b5447e11a914684cb376e.tar.gz
gnu: Add emacs-csound-mode.
* gnu/packages/emacs-xyz.scm (emacs-csound-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e7a57d883..6848bcee10 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24141,6 +24141,41 @@ read-only, constant database that maps Emacs Lisp symbols to
 arbitrary Emacs Lisp objects.")
     (license license:gpl3+)))
 
+(define-public emacs-csound-mode
+  (package
+    (name "emacs-csound-mode")
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hlolli/csound-mode")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1c88ak0jaj51fwiqniqxd7xyk23wjl9m57znzm8j267ld8g12znp"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-breaking-compilation
+           (lambda _
+             (for-each (lambda (file)
+                         (chmod file #o600) ; needed to write changes.
+                         (emacs-batch-disable-compilation file))
+                       '("csound-font-lock.el"))
+             #t)))))
+    (inputs
+     `(("emacs-highlight" ,emacs-highlight)
+       ("emacs-multi" ,emacs-multi)
+       ("emacs-shut-up" ,emacs-shut-up)))
+    (home-page "https://github.com/hlolli/csound-mode")
+    (synopsis "Emacs major mode for coding in CSound")
+    (description "Provides both a basic major mode for editing
+CSound files, as well as a REPL for fast feedback when composing
+and sonud-designing.")
+    (license license:gpl3+)))
 
 (define-public emacs-multi
   (package