summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2016-11-28 16:30:07 -0800
committerLudovic Courtès <ludo@gnu.org>2017-01-09 15:55:57 +0100
commit392c26b0d1edc4ead2f3e4d507a334dd3ae8a12f (patch)
treee79a7b5c77edb483b69bd5c3d8e9f77f9e43a901
parent814b18e5870ae1bef46313b3bc45649583a3d240 (diff)
downloadguix-392c26b0d1edc4ead2f3e4d507a334dd3ae8a12f.tar.gz
gnu: python-pip: Update to 9.0.1
* gnu/packages/python.scm (python-pip): Update to 9.0.1.
[native-inputs]: Remove.
[arguments]: New field.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13e0287dde..1fd02f7a0b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6771,26 +6771,21 @@ library.")
 (define-public python-pip
   (package
     (name "python-pip")
-    (version "8.0.2")
+    (version "9.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pip" version))
        (sha256
         (base32
-         "08cm8d4228fj0qnrysy3qv1a6022zr3dcs25amd14lgxil6vvx26"))))
+         "03clr9c1dih5n9c00c592zzvf6r1ffimywkaq9agcqdllzhl7wh9"))))
     (build-system python-build-system)
-    (native-inputs
-      `(;; Tests
-        ("python-virtualenv" ,python-virtualenv)
-        ("python-mock" ,python-mock)
-        ("python-pytest" ,python-pytest)
-        ("python-scripttest" ,python-scripttest)))
+    (arguments
+     '(#:tests? #f))          ; there are no tests in the pypi archive.
     (home-page "https://pip.pypa.io/")
-    (synopsis
-      "Package manager for Python software")
+    (synopsis "Package manager for Python software")
     (description
-      "Pip is a package manager for Python software, that finds packages on the
+     "Pip is a package manager for Python software, that finds packages on the
 Python Package Index (PyPI).")
     (license license:expat)))