summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 13:02:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:17:55 +0300
commitba24828805a3904b141a1afb5a5bb1b13b668f22 (patch)
tree1f78903a4f2a9a239d41430edb93c0cfb8a5a185
parent105d4ee2dfa2297482f4a2503802b79d679675c7 (diff)
downloadguix-ba24828805a3904b141a1afb5a5bb1b13b668f22.tar.gz
gnu: Add perl-class-errorhandler.
* gnu/packages/perl.scm (perl-class-errorhandler): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index aef92f4b79..4e3d1fa8d0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -700,6 +700,27 @@ subclasses and can be overridden.")
 type for perl.")
     (license (package-license perl))))
 
+(define-public perl-class-errorhandler
+  (package
+    (name "perl-class-errorhandler")
+    (version "0.04")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/T/TO/TOKUHIROM/"
+                                  "Class-ErrorHandler-" version ".tar.gz"))
+              (sha256
+               (base32
+                "00j5f0z4riyq7i95jww291dpmbn0hmmvkcbrh7p0p8lpqz7jsb9l"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Class-ErrorHandler")
+    (synopsis "Base class for error handling")
+    (description
+     "@code{Class::ErrorHandler} provides an error-handling mechanism that is generic
+enough to be used as the base class for a variety of OO classes.  Subclasses inherit
+its two error-handling methods, error and errstr, to communicate error messages back
+to the calling program.")
+    (license (package-license perl))))
+
 (define-public perl-class-factory-util
   (package
     (name "perl-class-factory-util")