summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-04-22 23:35:47 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-04-26 15:59:09 +0200
commit2766f9e84f657a7e5443759dc2d4def91e9ceb45 (patch)
treeb8de53d7481633486814bba8f7c53c1f029eb5c6
parentfadae857b7fa07a657888b5fa9bdd2f8d024fccc (diff)
downloadguix-2766f9e84f657a7e5443759dc2d4def91e9ceb45.tar.gz
gnu: Add volk.
Fixes <http://bugs.gnu.org/26614>.

* gnu/packages/engineering.scm (volk): New variable.
-rw-r--r--gnu/packages/engineering.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index dd56af99da..20efe11a24 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -774,3 +774,29 @@ render model libraries.")
 educational use.  As such, there is an emphasis on capabilities that improve
 the 'showing the effect of'-style of operation.")
     (license license:gpl2+)))
+
+(define-public volk
+  (package
+    (name "volk")
+    (version "1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://libvolk.org/releases/volk-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("boost" ,boost)))
+    (native-inputs
+     `(("python-2", python-2)
+       ("python2-cheetah" ,python2-cheetah)))
+    (home-page "http://libvolk.org/")
+    (synopsis "Vector-Optimized Library of Kernels")
+    (description
+     "@code{volk} contains procedures with machine-specific optimizations
+for mathematical functions.  It also provides an machine-independent
+interface to select the best such procedures to use on a given system.")
+    (license license:gpl3+)))