summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-12-03 08:38:44 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-12-03 09:22:30 +0100
commit5587253a8786beca5b270ac72cc68802b72b7539 (patch)
tree3a2dbca13d85ecb550414f5e4e133851ba210ca0
parent084e41c1ac0ba3d37426ef71ecf6e7dab0c1ffdb (diff)
downloadguix-5587253a8786beca5b270ac72cc68802b72b7539.tar.gz
gnu: python2-ipython: Use custom 'python2-numpy'.
* gnu/packages/python.scm (python2-ipython): Do it.
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 45222e9984..71853dc721 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4246,8 +4246,9 @@ computing.")
       (inputs
        `(("python2-mock" ,python2-mock)
          ("python2-matplotlib" ,python2-matplotlib)
-         ,@(alist-delete "python-matplotlib"
-                         (package-inputs ipython)))))))
+         ("python2-numpy" ,python2-numpy)
+         ,@(fold alist-delete (package-inputs ipython)
+                 '("python-matplotlib" "python-numpy")))))))
 
 (define-public python-isodate
   (package