summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-22 09:25:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-23 11:34:45 +0200
commit769df80ded6057548a31571a49bc60cc8cf8f0be (patch)
tree57650fbe8100153907220c3f658c599709219527
parent644f95111cd3566b2136f935624a82210eec2c8a (diff)
downloadguix-769df80ded6057548a31571a49bc60cc8cf8f0be.tar.gz
gnu: nss: Further increase test timeouts on armhf.
* gnu/packages/gnuzilla.scm (nss)[arguments]<#:phases>: Add a substitution
when target platform is armhf.
-rw-r--r--gnu/packages/gnuzilla.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index efe63adb4d..d60b53828b 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -241,6 +241,16 @@ in the Mozilla clients.")
                   `((setenv "USE_64" "1")))
                  (_
                   '()))
+             ;; The timeout values in "increase-test-timeouts" are still
+             ;; too low, so apply this workaround on armhf for now to avoid
+             ;; rebuilding on all platforms. This should be incorporated in
+             ;; the patch for the next update.
+             ;; https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00472.html
+             ,@(if (string-prefix? "armhf" (or (%current-target-system)
+                                               (%current-system)))
+                   `((substitute* "nss/gtests/ssl_gtest/tls_connect.cc"
+                       (("25000\\);") "300000);")))
+                   '())
              #t))
          (replace 'check
            (lambda _