summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-10-17 10:30:58 +0000
committerKei Kebreau <kei@openmailbox.org>2017-03-02 14:02:00 -0500
commita80488c20481e2a86a1808b85530342cf119b424 (patch)
tree312ab7959b7812915ac5dac6dd8bce4a6a350569
parentde959250411830584366a0397367032f10c3c352 (diff)
downloadguix-a80488c20481e2a86a1808b85530342cf119b424.tar.gz
gnu: Add python-pykka.
* gnu/packages/python.scm (python-pykka): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a2f0db74fa..0bfc8598ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2648,6 +2648,35 @@ somewhat intelligeble.")
 (define-public python2-pyjwt
   (package-with-python2 python-pyjwt))
 
+(define-public python-pykka
+  (package
+    (name "python-pykka")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Pykka" version))
+       (sha256
+        (base32
+         "049w3r0mdnnw7xv19jiq7rvls9k7xs73x05b4qs5d6z4vvmgyiz8"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)
+       ("python-gevent" ,python-gevent)
+       ("python-eventlet" ,python-eventlet)))
+    (home-page "https://www.pykka.org/")
+    (synopsis "Pykka is a Python implementation of the actor model")
+    (description
+     "Pykka is a Python implementation of the actor model.
+The actor model introduces some simple rules to control the sharing
+of state and cooperation between execution units, which makes it
+easier to build concurrent applications.")
+    (license license:asl2.0)))
+
+(define-public python2-pykka
+  (package-with-python2 python-pykka))
+
 (define-public python-oauthlib
   (package
     (name "python-oauthlib")