summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-21 12:27:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-21 12:32:54 +0200
commitef27b4345f4013fca81a6de445e865c09c0fbfdb (patch)
tree83f89667afcca5e39593e84f153af07a28b6c8bf
parentfea8b72989362a605dde74280a5789822114f7e2 (diff)
downloadguix-ef27b4345f4013fca81a6de445e865c09c0fbfdb.tar.gz
gnu: fortify-headers: Use @code mark-up.
* gnu/packages/suckless.scm (fortify-headers)[description]: Use @code.
-rw-r--r--gnu/packages/suckless.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index bace180061..a87e665d2b 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -586,16 +586,16 @@ environment variable.")
      "This is a standalone implementation of fortify source.  It provides
 compile time buffer checks.  It is libc-agnostic and simply overlays the
 system headers by using the @code{#include_next} extension found in GCC.  It was
-initially intended to be used on musl based Linux distributions.
+initially intended to be used on musl-based Linux distributions.
 
 @itemize
 @item It is portable, works on *BSD, Linux, Solaris and possibly others.
 @item It will only trap non-conformant programs.  This means that fortify
   level 2 is treated in the same way as level 1.
 @item Avoids making function calls when undefined behaviour has already been
-  invoked.  This is handled by using __builtin_trap().
-@item Support for out-of-bounds read interfaces, such as send(), write(),
-  fwrite() etc.
+  invoked.  This is handled by using @code{__builtin_trap()}.
+@item Support for out-of-bounds read interfaces, such as @code{send()},
+  @code{write()}, @code{fwrite()}, etc.
 @item No ABI is enforced.  All of the fortify check functions are inlined
   into the resulting binary.
 @end itemize\n")