summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-07-18 21:23:58 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-07-19 08:40:22 -0400
commit000f7559a7a14126d5bb44eebcc9fd6959c288e8 (patch)
treeba36e14025e5a593bfa9bd38de5bf8d3ecbfb651
parent66c2703f092f346e00e61a0a86ca4e2331756db5 (diff)
downloadguix-000f7559a7a14126d5bb44eebcc9fd6959c288e8.tar.gz
gnu: Add wireless-tools.
* gnu/packages/linux.scm (wireless-tools): New variable.
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b9864f4f44..6e307e5938 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1329,3 +1329,29 @@ from the module-init-tools project.")
 device nodes from /dev/, handles hotplug events and loads drivers at boot
 time.")
     (license gpl2+))) ; libudev is under lgpl2.1+
+
+(define-public wireless-tools
+  (package
+    (name "wireless-tools")
+    (version "30.pre9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools."
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0qscyd44jmhs4k32ggp107hlym1pcyjzihiai48xs7xzib4wbndb"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (alist-replace
+                 'configure
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (setenv "PREFIX" (assoc-ref outputs "out")))
+                 %standard-phases)
+       #:tests? #f))
+    (synopsis "Tools for manipulating Linux Wireless Extensions")
+    (description "Wireless Tools are used to manipulate the Linux Wireless
+Extensions.  The Wireless Extension is an interface allowing you to set
+Wireless LAN specific parameters and get the specific stats.")
+    (home-page "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html")
+    (license gpl2+)))