summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-06 14:06:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-06 14:06:16 +0200
commit03f4500118eb89a36d6c4978a993c0424b7d8aa4 (patch)
tree59de77c015c47f4e2830a3ab9fbe018255fb0a21
parent251785941159fe57d28558381ab580433fc78099 (diff)
downloadguix-03f4500118eb89a36d6c4978a993c0424b7d8aa4.tar.gz
gnu: gdb: Add dependency on libxml2.
* gnu/packages/gdb.scm (gdb)[inputs]: Add LIBXML2.
-rw-r--r--gnu/packages/gdb.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index f521ef5839..a786383027 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -57,7 +57,11 @@
        ("readline" ,readline)
        ("ncurses" ,ncurses)
        ("python" ,python-wrapper)
-       ("dejagnu" ,dejagnu)))
+       ("dejagnu" ,dejagnu)
+
+       ;; Allow use of XML-formatted syscall information.  This enables 'catch
+       ;; syscall' and similar commands.
+       ("libxml2" ,libxml2)))
     (native-inputs
       `(("texinfo" ,texinfo)))
     (home-page "http://www.gnu.org/software/gdb/")