summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 08:36:52 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:23 -0400
commit05e34109824b181b8c42f2e6573d8784e6145c87 (patch)
tree75d51e7f8f732f105f407b386fc9ede498a236ff
parent836835566a35c0cb1ae45e435cd64af9e4b10a4f (diff)
downloadguix-05e34109824b181b8c42f2e6573d8784e6145c87.tar.gz
gnu: gtk+: Enable cloud-providers support.
* gnu/packages/gtk.scm (gtk+) [arguments]<#:configure-flags>
[--enable-cloudproviders]: New flag.
[propagated-inputs]: Add libcloudproviders.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dd6590ca43..4253a1aed7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -959,6 +959,7 @@ application suites.")
                           gdk-pixbuf+svg
                           gdk-pixbuf))
        ("glib" ,glib)
+       ("libcloudproviders" ,libcloudproviders)
        ("libepoxy" ,libepoxy)
        ("libx11" ,libx11)
        ("libxcomposite" ,libxcomposite)
@@ -1010,6 +1011,7 @@ application suites.")
        #:configure-flags (list (string-append "--with-html-dir="
                                               (assoc-ref %outputs "doc")
                                               "/share/gtk-doc/html")
+                               "--enable-cloudproviders"
                                ;; The header file <gdk/gdkwayland.h> is required
                                ;; by gnome-control-center
                                "--enable-wayland-backend"