summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-09 14:06:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-09 14:06:07 +0200
commit18160c3408a6481f70e7f15afe5009edd2a731ae (patch)
tree915b4b97f7eb892c186b32f1e67d31c5ebae7221
parentaeb1ed1abcc953694bcd742ae5e3ba5a13506373 (diff)
downloadguix-18160c3408a6481f70e7f15afe5009edd2a731ae.tar.gz
gnu: Use mirror://kernel.org in source URIs.
* gnu/packages/linux.scm (bridge-utils, cpufrequtils, sbc)[source](uri): Use
"mirror://kernel.org" instead of www.kernel.org directly.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 999e4c8643..80c1551825 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1514,8 +1514,8 @@ Linux-based operating systems.")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://www.kernel.org/pub/linux/utils/net/"
-                           "bridge-utils/bridge-utils-" version ".tar.xz"))
+       (uri (string-append "mirror://kernel.org/linux/utils/net/bridge-utils/"
+                           "bridge-utils-" version ".tar.xz"))
        (sha256
         (base32 "1j16kr44csyr4yqxly26l1yw2bh4nkiasgwvask2i2gvsnsyyryc"))))
     (build-system gnu-build-system)
@@ -2987,10 +2987,8 @@ also contains the libsysfs library.")
     (source
      (origin
        (method url-fetch)
-       (uri
-        (string-append
-         "https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-"
-         version ".tar.gz"))
+       (uri (string-append "mirror://kernel.org/linux/utils/kernel/cpufreq/"
+                           "cpufrequtils-" version ".tar.gz"))
        (sha256
         (base32 "0qfqv7nqmjfr3p0bwrdlxkiqwqr7vmx053cadaa548ybqbghxmvm"))
        (patches (search-patches "cpufrequtils-fix-aclocal.patch"))))
@@ -3269,8 +3267,8 @@ applications.")
     (version "1.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://www.kernel.org/pub/linux/bluetooth/"
-                                  name "-" version ".tar.xz"))
+              (uri (string-append "mirror://kernel.org/linux/bluetooth/sbc-"
+                                  version ".tar.xz"))
               (sha256
                (base32
                 "02ckd2z51z0h85qgv7x8vv8ybp5czm9if1z78411j53gaz7j4476"))))