summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:02 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:02 +0200
commit1e92287d41771765edd6e42513afc83c64d6df4e (patch)
tree77dfb518488d5f61764a29296589677e4e74c7e5
parent7e488f9991cfec1ef9e8ca5d1910a65920ab2750 (diff)
downloadguix-1e92287d41771765edd6e42513afc83c64d6df4e.tar.gz
gnu: Add python-jsonpointer.
* gnu/packages/python.scm (python-jsonpointer, python2-jsonpointer):
New variables.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 07f4f812c7..9676e33445 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15079,3 +15079,24 @@ create data based on random numbers and yet remain repeatable.")
 
 (define-public python2-nose-randomly
   (package-with-python2 python-nose-randomly))
+
+(define-public python-jsonpointer
+  (package
+    (name "python-jsonpointer")
+    (version "1.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jsonpointer" version))
+       (sha256
+        (base32
+         "1cg0gvgqjysydv6p45v4jywg1jb3v48c7m3cbpi57zgf6nndr9cz"))))
+  (build-system python-build-system)
+  (home-page "https://github.com/stefankoegl/python-json-pointer")
+  (synopsis "Identify specific nodes in a JSON document")
+  (description "@code{jsonpointer} allows you to access specific nodes
+by path in a JSON document (see RFC 6901).")
+  (license license:bsd-3)))
+
+(define-public python2-jsonpointer
+  (package-with-python2 python-jsonpointer))